summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-03-27 09:28:01 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-03-27 09:28:01 +0000
commitb777a1a889fa0a72cf53efd7afe5a925fcecb71e (patch)
treeea568adc71bf59a1c6fc0dfdccf0f77ecb145a6b /sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild
parent2.1_pre7-r2 regression fix revbump (diff)
downloadhistorical-b777a1a889fa0a72cf53efd7afe5a925fcecb71e.tar.gz
historical-b777a1a889fa0a72cf53efd7afe5a925fcecb71e.tar.bz2
historical-b777a1a889fa0a72cf53efd7afe5a925fcecb71e.zip
Removing softlink patch as it breaks the package. Revbumping to force upgrade. See http://forums.gentoo.org/viewtopic-t-446715.html .
Package-Manager: portage-2.1_pre6-r6
Diffstat (limited to 'sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild')
-rw-r--r--sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild b/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild
new file mode 100644
index 000000000000..20b84978d12a
--- /dev/null
+++ b/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild,v 1.1 2006/03/27 09:28:01 eradicator Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="HFS FS Access utils"
+HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
+SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE="tcltk"
+
+DEPEND="tcltk? ( dev-lang/tcl dev-lang/tk )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/hfsutils-3.2.6-errno.patch
+ epatch "${FILESDIR}"/largerthan2gb.patch
+}
+
+src_compile() {
+ tc-export CC CPP LD RANLIB
+ econf \
+ $(use_with tcltk tcl) \
+ $(use_with tcltk tk) \
+ || die
+ emake PREFIX=/usr MANDIR=/usr/share/man || die
+ emake -C hfsck PREFIX=/usr MANDIR=/usr/share/man || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/lib /usr/share/man/man1
+ make \
+ prefix="${D}"/usr \
+ MANDEST="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ install || die
+ dobin hfsck/hfsck || die
+ dodoc BLURB CHANGES README TODO doc/*.txt
+}