summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrent Baude <ranger@gentoo.org>2005-08-22 17:53:08 +0000
committerBrent Baude <ranger@gentoo.org>2005-08-22 17:53:08 +0000
commite32239ace16ee9fae35740e1a718154a2a67f514 (patch)
treedbafe1d4e3aa98fc558a8c7a1a001b1dd5c2ca7f /sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild
parentUpdate to CVS as of 20050822. This should make amd64 and sparc work. Update i... (diff)
downloadhistorical-e32239ace16ee9fae35740e1a718154a2a67f514.tar.gz
historical-e32239ace16ee9fae35740e1a718154a2a67f514.tar.bz2
historical-e32239ace16ee9fae35740e1a718154a2a67f514.zip
Adding iprutils-2.0.15.3-r1 which references a newer version of iprdd, sysfsutils-1.3, and introduces three new init.d scripts
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild')
-rw-r--r--sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild b/sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild
new file mode 100644
index 000000000000..7b6f6633389f
--- /dev/null
+++ b/sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/iprutils/iprutils-2.0.15.3-r1.ebuild,v 1.1 2005/08/22 17:53:07 ranger Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="IBM's tools for support of the ipr SCSI controller"
+SRC_URI="mirror://sourceforge/iprdd/${P}-src.tgz"
+HOMEPAGE="http://sourceforge.net/projects/iprdd/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="~ppc64"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.4-r5
+ >=sys-apps/pciutils-2.1.11-r1
+ >=sys-fs/sysfsutils-1.3.0"
+
+src_install () {
+ make INSTALL_MOD_PATH=${D} install || die
+ dodoc ChangeLog LICENSE
+
+ dodir /etc/init.d
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/iprinit iprinit
+ newexe ${FILESDIR}/iprupdate iprupdate
+ newexe ${FILESDIR}/iprdump iprdump
+}
+
+pkg_postinst() {
+ einfo "This package also contains several init.d files. "
+ einfo "You should add them to your default runlevels as follows:"
+ einfo "rc-update add iprinit default"
+ einfo "rc-update add iprdump default"
+ einfo "rc-update add iprupdate default"
+ ebeep 5
+}