summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-08 03:40:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-08 03:40:49 +0000
commitc40c89c120d220b5e68545333c5f045b6c0aaea8 (patch)
treed57360d9de4325f9700fb8ddb195579eb08f6241 /sys-fs/mtd-utils/mtd-utils-20060606.ebuild
parentAdded ~alpha keyword. Tested with Linksys ADMtek ADM8211 802.11b Wireless Int... (diff)
downloadhistorical-c40c89c120d220b5e68545333c5f045b6c0aaea8.tar.gz
historical-c40c89c120d220b5e68545333c5f045b6c0aaea8.tar.bz2
historical-c40c89c120d220b5e68545333c5f045b6c0aaea8.zip
Initial commit. New variant of the old sys-fs/mtd package, maintained seperately by upstream.
Package-Manager: portage-2.1_rc4-r4
Diffstat (limited to 'sys-fs/mtd-utils/mtd-utils-20060606.ebuild')
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20060606.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/mtd-utils/mtd-utils-20060606.ebuild b/sys-fs/mtd-utils/mtd-utils-20060606.ebuild
new file mode 100644
index 000000000000..1bacdb1c6545
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-20060606.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20060606.ebuild,v 1.1 2006/06/08 03:40:48 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream"
+HOMEPAGE="http://sources.redhat.com/jffs2/"
+SRC_URI="mirror://gentoo/${PN}-snapshot-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~mips ~arm ~amd64 ~ppc"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+DEPEND="sys-libs/zlib
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ sed -i.orig \
+ -e 's!^MANDIR.*!MANDIR = /usr/share/man!g' \
+ -e 's!-include.*!!g' \
+ ${S}/Makefile
+}
+
+src_compile() {
+ append-flags -I./include -Wall
+ emake DESTDIR="${D}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc *.txt
+}