summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-18 02:01:56 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-18 02:01:56 +0000
commite4cdaa8f2133c5972b115c2398052dc7c99b9e15 (patch)
tree520c96895a0c2a8df242f284166915785f3dcf70 /sys-fs/mtools/mtools-4.0.15.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-e4cdaa8f2133c5972b115c2398052dc7c99b9e15.tar.gz
historical-e4cdaa8f2133c5972b115c2398052dc7c99b9e15.tar.bz2
historical-e4cdaa8f2133c5972b115c2398052dc7c99b9e15.zip
Version bump.
Package-Manager: portage-2.2_rc97/cvs/Linux i686
Diffstat (limited to 'sys-fs/mtools/mtools-4.0.15.ebuild')
-rw-r--r--sys-fs/mtools/mtools-4.0.15.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/mtools/mtools-4.0.15.ebuild b/sys-fs/mtools/mtools-4.0.15.ebuild
new file mode 100644
index 000000000000..9f4ee500da56
--- /dev/null
+++ b/sys-fs/mtools/mtools-4.0.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtools/mtools-4.0.15.ebuild,v 1.1 2010/10/18 02:01:56 jer Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
+HOMEPAGE="http://mtools.linux.lu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+DEPEND="
+ X? (
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/usr/local/etc:/etc:g' mtools.5 mtools.texi
+ eautoconf #341443
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/mtools \
+ $(use_with X x)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ insinto /etc/mtools
+ doins mtools.conf || die
+ dosed '/^SAMPLE FILE$/s:^:#:' /etc/mtools/mtools.conf # default is fine
+ dodoc README* Release.notes
+}