summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-12 17:56:17 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-12 17:56:17 +0000
commita15f6c160316af2d7e6666c4d10e2f428699fdd5 (patch)
tree298baaa4ab68ff772653c94049edb38b292d029b /sys-fs/xfsdump
parentclean up patch (diff)
downloadhistorical-a15f6c160316af2d7e6666c4d10e2f428699fdd5.tar.gz
historical-a15f6c160316af2d7e6666c4d10e2f428699fdd5.tar.bz2
historical-a15f6c160316af2d7e6666c4d10e2f428699fdd5.zip
Version bump #363261 by Lars Wendler.
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog10
-rw-r--r--sys-fs/xfsdump/files/xfsdump-3.0.5-prompt-overflow.patch14
-rw-r--r--sys-fs/xfsdump/xfsdump-3.0.5.ebuild49
3 files changed, 71 insertions, 2 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 4026987836e8..0f8bf9490508 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/xfsdump
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.78 2010/08/29 22:21:49 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.79 2011/04/12 17:56:17 vapier Exp $
+
+*xfsdump-3.0.5 (12 Apr 2011)
+
+ 12 Apr 2011; Mike Frysinger <vapier@gentoo.org> +xfsdump-3.0.5.ebuild,
+ +files/xfsdump-3.0.5-prompt-overflow.patch:
+ Version bump #363261 by Lars Wendler.
29 Aug 2010; Mike Frysinger <vapier@gentoo.org> xfsdump-3.0.4-r1.ebuild,
+files/xfsdump-3.0.4-headers.patch:
diff --git a/sys-fs/xfsdump/files/xfsdump-3.0.5-prompt-overflow.patch b/sys-fs/xfsdump/files/xfsdump-3.0.5-prompt-overflow.patch
new file mode 100644
index 000000000000..053615c8dca4
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-3.0.5-prompt-overflow.patch
@@ -0,0 +1,14 @@
+http://oss.sgi.com/bugzilla/show_bug.cgi?id=876
+https://bugs.gentoo.org/335115
+
+--- dump/content.c
++++ dump/content.c
+@@ -6460,7 +6460,7 @@
+ Media_prompt_erase( drive_t *drivep )
+ {
+ fold_t fold;
+- char question[ 100 ];
++ char question[ 200 ];
+ char *preamblestr[ PREAMBLEMAX ];
+ size_t preamblecnt;
+ char *querystr[ QUERYMAX ];
diff --git a/sys-fs/xfsdump/xfsdump-3.0.5.ebuild b/sys-fs/xfsdump/xfsdump-3.0.5.ebuild
new file mode 100644
index 000000000000..d50658c21b16
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.5.ebuild,v 1.1 2011/04/12 17:56:17 vapier Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsprogs-3
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}