summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-11-13 17:28:41 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-11-13 17:28:41 +0000
commitbc1f46a573c6b85ba0b7a8571cb66542b1a89605 (patch)
tree9765111e0085ead836807584f29037e6a62b2631 /sys-fs
parentVersion bump, bug #33358. (diff)
downloadhistorical-bc1f46a573c6b85ba0b7a8571cb66542b1a89605.tar.gz
historical-bc1f46a573c6b85ba0b7a8571cb66542b1a89605.tar.bz2
historical-bc1f46a573c6b85ba0b7a8571cb66542b1a89605.zip
Version bump, bug #33358.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/Manifest4
-rw-r--r--sys-fs/xfsprogs/files/digest-xfsprogs-2.6.01
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.6.0.ebuild55
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index e4dbe850de2c..3800b27811b9 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,6 +1,6 @@
-MD5 92d0189aa20c315766798b4fe7d6df96 ChangeLog 4142
+MD5 e436d346cdaecad7c30b22f4e74388a5 ChangeLog 4146
MD5 9cd0553a87a3cd46668c02b31c669143 xfsprogs-1.3.13.ebuild 1367
-MD5 0622cf45170c8cd43f6e4e8204fc7e4d xfsprogs-2.6.0.ebuild 1358
+MD5 5b4c6818d4e4466d0744a422fd3eb9a3 xfsprogs-2.6.0.ebuild 1461
MD5 f3581f138735c6ee2e48927f220d065a xfsprogs-2.3.9.ebuild 1451
MD5 0ad03e88abe9cb756d16c8b202804fbc files/digest-xfsprogs-2.3.9 70
MD5 ed760013d5e82b9e87430f596ba7b76c files/digest-xfsprogs-2.6.0 70
diff --git a/sys-fs/xfsprogs/files/digest-xfsprogs-2.6.0 b/sys-fs/xfsprogs/files/digest-xfsprogs-2.6.0
new file mode 100644
index 000000000000..51504d8fdfa1
--- /dev/null
+++ b/sys-fs/xfsprogs/files/digest-xfsprogs-2.6.0
@@ -0,0 +1 @@
+MD5 4336c70c0054029ad060c2e7a2d4e848 xfsprogs-2.6.0.src.tar.gz 832823
diff --git a/sys-fs/xfsprogs/xfsprogs-2.6.0.ebuild b/sys-fs/xfsprogs/xfsprogs-2.6.0.ebuild
new file mode 100644
index 000000000000..5302cb9b3eb5
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-2.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.0.ebuild,v 1.1 2003/11/13 17:28:31 plasmaroo Exp $
+
+inherit flag-o-matic
+
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+DESCRIPTION="xfs filesystem utilities"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~amd64 ~alpha ~mips ~hppa ~ia64 ~ppc"
+
+S=${WORKDIR}/${P}
+
+DEPEND="sys-fs/e2fsprogs
+ sys-devel/autoconf
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ chmod u+w include/builddefs.in
+ sed -i -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' -e '/-S $(PKG/d' \
+ -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
+ include/builddefs.in || die "sed failed"
+}
+
+src_compile() {
+ replace-flags -O[2-9] -O1
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+
+ autoconf || die
+
+ ./configure --prefix=/usr \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --libdir=/lib \
+ --libexecdir=/lib \
+ --mandir=/usr/share/man || die "config failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || die "make install failed"
+
+ cat ${S}/libhandle/.libs/libhandle.la | sed -e 's:installed=no:installed=yes:g' > ${D}/lib/libhandle.la
+
+ dosym /lib/libhandle.so.1 /lib/libhandle.so
+}