summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-11-04 10:09:55 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-11-04 10:09:55 +0000
commitb4251483a8993298bcf28af79c1b577d7bf56a63 (patch)
tree13d828e96714c8bc90866f2ef8e927d98d24283e /sys-kernel/ck-sources
parentx86 stable wrt bug #343371 (diff)
downloadhistorical-b4251483a8993298bcf28af79c1b577d7bf56a63.tar.gz
historical-b4251483a8993298bcf28af79c1b577d7bf56a63.tar.bz2
historical-b4251483a8993298bcf28af79c1b577d7bf56a63.zip
Revision bump for new genpatches.
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog8
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.35-r6.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 6012abc9202a..1cc24dffe848 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.183 2010/10/22 17:30:26 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.184 2010/11/04 10:07:19 nelchael Exp $
+
+*ck-sources-2.6.35-r6 (04 Nov 2010)
+
+ 04 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.35-r6.ebuild:
+ Revision bump for new genpatches.
*ck-sources-2.6.36 (22 Oct 2010)
*ck-sources-2.6.35-r5 (22 Oct 2010)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.35-r6.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.35-r6.ebuild
new file mode 100644
index 000000000000..e36d0ab8be2a
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.35-r6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.35-r6.ebuild,v 1.1 2010/11/04 10:07:19 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION=""
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}