summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
commitf189db3f9e3b05eacfc9939c84930bbf40010522 (patch)
treec97d0d333738d237888aa492b6ecdd21e23dd0e0 /sys-kernel/ck-sources
parentfix src_uri (diff)
downloadhistorical-f189db3f9e3b05eacfc9939c84930bbf40010522.tar.gz
historical-f189db3f9e3b05eacfc9939c84930bbf40010522.tar.bz2
historical-f189db3f9e3b05eacfc9939c84930bbf40010522.zip
Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog6
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild4
-rw-r--r--sys-kernel/ck-sources/files/ck-sources-2.6.9.AF_UNIX.patch24
3 files changed, 31 insertions, 3 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 1b50cc81794f..a47d2cb47b35 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.70 2004/11/27 17:49:41 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.71 2004/11/28 11:52:23 plasmaroo Exp $
+
+ 28 Nov 2004; <plasmaroo@gentoo.org> ck-sources-2.6.9-r3.ebuild,
+ +files/ck-sources-2.6.9.AF_UNIX.patch:
+ Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
*ck-sources-2.4.27-r4 (27 Nov 2004)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild
index 3ce69ae0d82a..240fff4c70ed 100644
--- a/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild,v 1.5 2004/11/27 17:49:41 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.9-r3.ebuild,v 1.6 2004/11/28 11:52:23 plasmaroo Exp $
UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2
${FILESDIR}/${P}.binfmt_elf.patch
${FILESDIR}/${P}.binfmt_a.out.patch
- ${FILESDIR}/${PN}.AF_UNIX.patch"
+ ${FILESDIR}/${P}.AF_UNIX.patch"
K_PREPATCHED="yes"
UNIPATCH_STRICTORDER="yes"
diff --git a/sys-kernel/ck-sources/files/ck-sources-2.6.9.AF_UNIX.patch b/sys-kernel/ck-sources/files/ck-sources-2.6.9.AF_UNIX.patch
new file mode 100644
index 000000000000..a95e94fd9362
--- /dev/null
+++ b/sys-kernel/ck-sources/files/ck-sources-2.6.9.AF_UNIX.patch
@@ -0,0 +1,24 @@
+--- linux-2.6.9/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
++++ linux-2.6.9.plasmaroo/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
+@@ -1535,9 +1535,11 @@
+
+ msg->msg_namelen = 0;
+
++ down(&u->readsem);
++
+ skb = skb_recv_datagram(sk, flags, noblock, &err);
+ if (!skb)
+- goto out;
++ goto out_unlock;
+
+ wake_up_interruptible(&u->peer_wait);
+
+@@ -1587,6 +1589,8 @@
+
+ out_free:
+ skb_free_datagram(sk,skb);
++out_unlock:
++ up(&u->readsem);
+ out:
+ return err;
+ }