summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-01-09 14:55:44 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-01-09 14:55:44 +0000
commit0e1cded2dd85f7a1dcaf0fb3ee5a2cc280795e1b (patch)
tree1358acbd8b543837ceccdbe428828c1ba37d591d /sys-kernel/development-sources
parentVersion bump. (diff)
downloadhistorical-0e1cded2dd85f7a1dcaf0fb3ee5a2cc280795e1b.tar.gz
historical-0e1cded2dd85f7a1dcaf0fb3ee5a2cc280795e1b.tar.bz2
historical-0e1cded2dd85f7a1dcaf0fb3ee5a2cc280795e1b.zip
Version bump.
Diffstat (limited to 'sys-kernel/development-sources')
-rw-r--r--sys-kernel/development-sources/Manifest4
-rw-r--r--sys-kernel/development-sources/development-sources-2.6.1.ebuild147
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.6.11
3 files changed, 150 insertions, 2 deletions
diff --git a/sys-kernel/development-sources/Manifest b/sys-kernel/development-sources/Manifest
index 04aee06b7604..905395e8992c 100644
--- a/sys-kernel/development-sources/Manifest
+++ b/sys-kernel/development-sources/Manifest
@@ -1,8 +1,8 @@
-MD5 93fb54aa47e2169f17c93a2ccfde397f ChangeLog 12424
+MD5 b056ac82f246f6786eff402a6c95eec9 ChangeLog 12424
MD5 854abf2bdb617fe8c7de18312a60bb85 metadata.xml 442
MD5 90684b19ee1d7f5c63fc6d06c421b406 development-sources-2.6.1_rc2.ebuild 2532
MD5 9785db32a3baed11804b3bfb074c9bb8 development-sources-2.6.1_rc1.ebuild 3506
-MD5 d0fe80ccd7e75b03ed5a68851a42561f development-sources-2.6.1.ebuild 4215
+MD5 b26e502e4db9435ad2db255b0715166a development-sources-2.6.1.ebuild 4215
MD5 f29561db005c7c4c5848361290521fef development-sources-2.6.1_rc3.ebuild 2532
MD5 fc184c339b6e767b30196b8bdbe72113 development-sources-2.6.0.ebuild 4220
MD5 b058d2842425a7a4bad9688d9e694309 files/digest-development-sources-2.6.0 66
diff --git a/sys-kernel/development-sources/development-sources-2.6.1.ebuild b/sys-kernel/development-sources/development-sources-2.6.1.ebuild
new file mode 100644
index 000000000000..3749a4f15da9
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.6.1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.1.ebuild,v 1.1 2004/01/09 14:55:33 plasmaroo Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#Original Kernel Version before Patches
+# eg: 2.6.0-test8
+OKV=${PV/_beta/-test}
+OKV=${OKV/-r*//}
+
+#Kernel version after patches
+# eg: 2.6.0-test8-bk1
+KV=${PF/_beta/-test}
+KV=${KV/-r/-bk}
+KV=${KV//${PN}-}
+
+#version of gentoo patchset
+# This should always be zero now, as this is back to vanilla
+GPV=0
+
+S=${WORKDIR}/linux-${OKV}
+ETYPE="sources"
+
+DESCRIPTION="Full sources for the Development Branch of the Linux kernel"
+
+
+# THIS IS VANILLA ONLY! DO NOT ADD PATCHES, USE gentoo-dev-sources FOR THAT !!!!!!
+[ ! ${GPV} == 0 ] && GPATCH_URI="mirror://gentoo/distfiles/genpatches-2.6-${GPV}.tar.bz2"
+[ -z ${KV/*-bk*/} ] && PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${KV}.bz2"
+
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 ${PATCH_URI} ${GPATCH_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* ~x86"
+PROVIDE="virtual/linux-sources virtual/alsa"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
+ sys-devel/make
+ sys-apps/module-init-tools"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ # apply bk pulls
+ if [ -z ${KV/*-bk*/} ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/patch-${KV}.bz2
+ cd ${WORKDIR}
+ fi
+
+ # apply gentoo patches
+ if [ ! ${GPV} == 0 ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2
+ KV="${KV}-patchset-${GPV}"
+ cd ${WORKDIR}
+ fi
+
+ # move to appropriate src dir
+ if [ ! ${KV} == ${OKV} ]
+ then
+ mv linux-${OKV} linux-${KV}
+ S=${WORKDIR}/linux-${KV}
+ fi
+
+ cd ${S}
+ unset ARCH
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0:0 *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+
+ [ "$ETYPE" = "headers" ] && return
+ [ ! ${GPV} == 0 ] && KV="${KV}-patchset-${GPV}"
+ [ ! -e "${ROOT}usr/src/linux-beta" ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ [ ! -e "${ROOT}usr/src/linux" ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ mkdir -p ${ROOT}sys
+
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "and you have to compile it in now, or else you will get"
+ ewarn "errors when trying to open a pty. The options are:"
+ ewarn "Device Drivers -> Character devices -> Unix98 PTY support and"
+ ewarn "File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "vga_console (Graphics Support->Console...->VGA text console)"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
+ ewarn "error."
+ echo
+ ewarn "PLEASE NOTE THIS IS NOT OFFICIALLY SUPPORTED BY GENTOO."
+ echo
+ sleep 5
+
+}
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.6.1 b/sys-kernel/development-sources/files/digest-development-sources-2.6.1
new file mode 100644
index 000000000000..e9195605e006
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.6.1
@@ -0,0 +1 @@
+MD5 fa82d1e4be518261b2eeb78eabf9cca7 linux-2.6.1.tar.bz2 33240033