summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2004-01-13 22:29:41 +0000
committerJohn Mylchreest <johnm@gentoo.org>2004-01-13 22:29:41 +0000
commit8821cf58984eaa0a07e307b1b4035b41ff52d604 (patch)
tree7568af027acbb8e76311b1f8667452ba1ca4bb26 /sys-kernel/development-sources
parentUpdated version, hard masked (diff)
downloadhistorical-8821cf58984eaa0a07e307b1b4035b41ff52d604.tar.gz
historical-8821cf58984eaa0a07e307b1b4035b41ff52d604.tar.bz2
historical-8821cf58984eaa0a07e307b1b4035b41ff52d604.zip
kernel-2 migration
Diffstat (limited to 'sys-kernel/development-sources')
-rw-r--r--sys-kernel/development-sources/Manifest14
-rw-r--r--sys-kernel/development-sources/development-sources-2.6.1.ebuild152
2 files changed, 22 insertions, 144 deletions
diff --git a/sys-kernel/development-sources/Manifest b/sys-kernel/development-sources/Manifest
index 905395e8992c..aaaea16a1e03 100644
--- a/sys-kernel/development-sources/Manifest
+++ b/sys-kernel/development-sources/Manifest
@@ -1,13 +1,13 @@
-MD5 b056ac82f246f6786eff402a6c95eec9 ChangeLog 12424
-MD5 854abf2bdb617fe8c7de18312a60bb85 metadata.xml 442
-MD5 90684b19ee1d7f5c63fc6d06c421b406 development-sources-2.6.1_rc2.ebuild 2532
-MD5 9785db32a3baed11804b3bfb074c9bb8 development-sources-2.6.1_rc1.ebuild 3506
-MD5 b26e502e4db9435ad2db255b0715166a development-sources-2.6.1.ebuild 4215
MD5 f29561db005c7c4c5848361290521fef development-sources-2.6.1_rc3.ebuild 2532
+MD5 9d4ae8c5a51362e197758c2901a09472 development-sources-2.6.1.ebuild 854
+MD5 90684b19ee1d7f5c63fc6d06c421b406 development-sources-2.6.1_rc2.ebuild 2532
MD5 fc184c339b6e767b30196b8bdbe72113 development-sources-2.6.0.ebuild 4220
+MD5 9785db32a3baed11804b3bfb074c9bb8 development-sources-2.6.1_rc1.ebuild 3506
+MD5 b056ac82f246f6786eff402a6c95eec9 ChangeLog 12424
+MD5 854abf2bdb617fe8c7de18312a60bb85 metadata.xml 442
MD5 b058d2842425a7a4bad9688d9e694309 files/digest-development-sources-2.6.0 66
-MD5 833b1e6abf21156db8d2488d4d83106c files/digest-development-sources-2.6.1_rc2 130
MD5 1f7aaa49614b3055b6110518b1ed23ee files/digest-development-sources-2.6.1 66
-MD5 3faaf1dfea087ee70743a0295b9e365d files/digest-development-sources-2.6.1_rc3 130
MD5 5e4b24d4c540af721c5bc7e3ad77f40b files/development-sources-2.6.1_rc1.CAN-2003-0985.patch 414
MD5 7723c79d5dac9a55773e01b60f8a2d65 files/digest-development-sources-2.6.1_rc1 70
+MD5 833b1e6abf21156db8d2488d4d83106c files/digest-development-sources-2.6.1_rc2 130
+MD5 3faaf1dfea087ee70743a0295b9e365d files/digest-development-sources-2.6.1_rc3 130
diff --git a/sys-kernel/development-sources/development-sources-2.6.1.ebuild b/sys-kernel/development-sources/development-sources-2.6.1.ebuild
index 3749a4f15da9..7d0898d0b3d8 100644
--- a/sys-kernel/development-sources/development-sources-2.6.1.ebuild
+++ b/sys-kernel/development-sources/development-sources-2.6.1.ebuild
@@ -1,147 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.1.ebuild,v 1.1 2004/01/09 14:55:33 plasmaroo Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.1.ebuild,v 1.2 2004/01/13 22:29:41 johnm Exp $
-#Original Kernel Version before Patches
-# eg: 2.6.0-test8
-OKV=${PV/_beta/-test}
-OKV=${OKV/-r*//}
-
-#Kernel version after patches
-# eg: 2.6.0-test8-bk1
-KV=${PF/_beta/-test}
-KV=${KV/-r/-bk}
-KV=${KV//${PN}-}
-
-#version of gentoo patchset
-# This should always be zero now, as this is back to vanilla
-GPV=0
-
-S=${WORKDIR}/linux-${OKV}
ETYPE="sources"
+inherit kernel-2
+detect_version
-DESCRIPTION="Full sources for the Development Branch of the Linux kernel"
-
-
-# THIS IS VANILLA ONLY! DO NOT ADD PATCHES, USE gentoo-dev-sources FOR THAT !!!!!!
-[ ! ${GPV} == 0 ] && GPATCH_URI="mirror://gentoo/distfiles/genpatches-2.6-${GPV}.tar.bz2"
-[ -z ${KV/*-bk*/} ] && PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${KV}.bz2"
-
-SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 ${PATCH_URI} ${GPATCH_URI}"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="-* ~x86"
-PROVIDE="virtual/linux-sources virtual/alsa"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
- sys-devel/make
- sys-apps/module-init-tools"
-fi
+DESCRIPTION="Full sources for the vanilla 2.6 kernel tree"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="${KERNEL_URI}"
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-
- # apply bk pulls
- if [ -z ${KV/*-bk*/} ]
- then
- cd ${S}
- epatch ${DISTDIR}/patch-${KV}.bz2
- cd ${WORKDIR}
- fi
-
- # apply gentoo patches
- if [ ! ${GPV} == 0 ]
- then
- cd ${S}
- epatch ${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2
- KV="${KV}-patchset-${GPV}"
- cd ${WORKDIR}
- fi
-
- # move to appropriate src dir
- if [ ! ${KV} == ${OKV} ]
- then
- mv linux-${OKV} linux-${KV}
- S=${WORKDIR}/linux-${KV}
- fi
-
- cd ${S}
- unset ARCH
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0:0 *
- chmod -R a+r-w+X,u+w *
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
+KEYWORDS="~x86 ~amd64"
pkg_postinst() {
-
- [ "$ETYPE" = "headers" ] && return
- [ ! ${GPV} == 0 ] && KV="${KV}-patchset-${GPV}"
- [ ! -e "${ROOT}usr/src/linux-beta" ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- [ ! -e "${ROOT}usr/src/linux" ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux
- mkdir -p ${ROOT}sys
-
- ewarn "Please note that ptyfs support has been removed from devfs"
- ewarn "and you have to compile it in now, or else you will get"
- ewarn "errors when trying to open a pty. The options are:"
- ewarn "Device Drivers -> Character devices -> Unix98 PTY support and"
- ewarn "File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ postinst_sources
+
+ ewarn "IMPORTANT:"
+ ewarn "ptyfs support has now been dropped from devfs and as a"
+ ewarn "result you are now required to compile this support into"
+ ewarn "the kernel. You can do so by enabling the following options"
+ ewarn " Device Drivers -> Character devices -> Unix98 PTY Support"
+ ewarn " File systems -> Pseudo filesystems -> /dev/pts filesystem."
echo
- ewarn "Also, note that you must compile in support for"
- ewarn "input devices (Input device support->Input devices),"
- ewarn "the virtual terminal (Character Devices->Virtual terminal),"
- ewarn "vga_console (Graphics Support->Console...->VGA text console)"
- ewarn "and the vt_console (Character Devices->Support for console...)."
- ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
- ewarn "error."
- echo
- ewarn "PLEASE NOTE THIS IS NOT OFFICIALLY SUPPORTED BY GENTOO."
- echo
- sleep 5
-
}