summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-24 05:48:38 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-24 05:48:38 +0000
commit04a095e7434e0cffa7751d3c9642d85b7752dab1 (patch)
tree87112ee3ddfa2905f8c380e1c65d529bb274cfc4 /sys-kernel/gentoo-sources
parentmove to stable for x86 (diff)
downloadhistorical-04a095e7434e0cffa7751d3c9642d85b7752dab1.tar.gz
historical-04a095e7434e0cffa7751d3c9642d85b7752dab1.tar.bz2
historical-04a095e7434e0cffa7751d3c9642d85b7752dab1.zip
unstable mask -r10
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/files/gentoo-sources-2.4.19-r9-quickfix.patch21
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild4
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild9
3 files changed, 9 insertions, 25 deletions
diff --git a/sys-kernel/gentoo-sources/files/gentoo-sources-2.4.19-r9-quickfix.patch b/sys-kernel/gentoo-sources/files/gentoo-sources-2.4.19-r9-quickfix.patch
index 7a38dd205240..1413cb536e37 100644
--- a/sys-kernel/gentoo-sources/files/gentoo-sources-2.4.19-r9-quickfix.patch
+++ b/sys-kernel/gentoo-sources/files/gentoo-sources-2.4.19-r9-quickfix.patch
@@ -9,24 +9,3 @@
#endif
/* filesystem internal functions */
---- linux/include/linux/skbuff.h Sun Sep 8 14:11:22 2002
-+++ linux/include/linux/skbuff.h.new Sun Sep 8 14:09:38 2002
-@@ -194,7 +194,7 @@
- unsigned char *end; /* End pointer */
-
- void (*destructor)(struct sk_buff *); /* Destruct function */
--#if defined ( CONFIG_NETFILTER || CONFIG_IPSEC )
-+#if defined(CONFIG_NETFILTER) || defined(CONFIG_IPSEC) || defined(CONFIG_IPSEC_MODULE)
- /* Can be used for communication between hooks. */
- unsigned long nfmark;
- /* Cache info */
---- linux-2.4.19-gentoo-r9/include/linux/netfilter_ipv4/ip_conntrack_core.h.o Thu Sep 19 16:51:11 2002
-+++ linux-2.4.19-gentoo-r9/include/linux/netfilter_ipv4/ip_conntrack_core.h Thu Sep 19 16:51:19 2002
-@@ -1,5 +1,7 @@
- #ifndef _IP_CONNTRACK_CORE_H
- #define _IP_CONNTRACK_CORE_H
-+
-+#include <linux/netfilter.h>
- #include <linux/netfilter_ipv4/lockhelp.h>
-
- /* This header is used to share core functionality between the
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild
index c17bbd21c158..e618783229ef 100644
--- a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild,v 1.2 2002/10/07 03:59:42 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r10.ebuild,v 1.3 2002/10/24 05:48:38 lostlogic Exp $
IUSE="build crypt xfs acpi4linux"
@@ -29,7 +29,7 @@ inherit kernel || die
DESCRIPTION="Full sources for the Gentoo Linux kernel"
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
-KEYWORDS="x86 -ppc -sparc -sparc64"
+KEYWORDS="~x86 -ppc -sparc -sparc64"
src_unpack() {
unpack ${A}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild
index 684b109683c9..2e40aa638f45 100644
--- a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild
@@ -56,8 +56,13 @@ src_unpack() {
chmod -R a+r-w+X,u+w *
cd ${S}
- # Tiny patch for symbol generation
- patch -p1 < ${FILESDIR}/gentoo-sources-2.4.19-r9-quickfix.patch || die
+ # Quick Fixes
+ patch -p1 < ${FILESDIR}/gentoo-sources-2.4.19-r9-quickfix.patch \
+ || die "Ksyms patch failed"
+ # Crypt only quickfix
+ [ `use crypt` ] && \
+ ( patch -p1<${FILESDIR}/gentoo-sources-2.4.19-r9-crypt.patch \
+ || die "crypt patch failed" )
# Gentoo Linux uses /boot, so fix 'make install' to work properly
# also fix the EXTRAVERSION
mv Makefile Makefile.orig