summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-14 21:47:29 +0000
committerNed Ludd <solar@gentoo.org>2003-08-14 21:47:29 +0000
commitb4047cd13a98651b2461f5173a1272f273e8ef04 (patch)
treec42813a9e7e2b17fc4c368e21ba20eee6a5638df /sys-kernel/grsec-sources
parentinitial import of grsec sources (diff)
downloadhistorical-b4047cd13a98651b2461f5173a1272f273e8ef04.tar.gz
historical-b4047cd13a98651b2461f5173a1272f273e8ef04.tar.bz2
historical-b4047cd13a98651b2461f5173a1272f273e8ef04.zip
initial import of grsec sources
Diffstat (limited to 'sys-kernel/grsec-sources')
-rw-r--r--sys-kernel/grsec-sources/Manifest5
-rw-r--r--sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.1.9.113
-rw-r--r--sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.2.0_rc23
-rw-r--r--sys-kernel/grsec-sources/grsec-sources-2.4.21.1.9.11.ebuild52
-rw-r--r--sys-kernel/grsec-sources/grsec-sources-2.4.21.2.0_rc2.ebuild52
-rw-r--r--sys-kernel/grsec-sources/metadata.xml10
6 files changed, 123 insertions, 2 deletions
diff --git a/sys-kernel/grsec-sources/Manifest b/sys-kernel/grsec-sources/Manifest
index 8f71c522e6e2..f8a746b98da2 100644
--- a/sys-kernel/grsec-sources/Manifest
+++ b/sys-kernel/grsec-sources/Manifest
@@ -1,5 +1,6 @@
-MD5 835e6b66e739712048d1bab069316938 grsec-sources-2.4.21.2.0_rc2.ebuild 1593
-MD5 835e6b66e739712048d1bab069316938 grsec-sources-2.4.21.1.9.11.ebuild 1593
+MD5 9089c9d8bb77456b8d35a6f25b268e23 grsec-sources-2.4.21.2.0_rc2.ebuild 1671
+MD5 852d21edf1e3eb9530a9bbac9610f804 grsec-sources-2.4.21.1.9.11.ebuild 1670
MD5 f546d12b85c9dc51d1707a31d9367487 metadata.xml 371
+MD5 4992dbeeee1e704aaf57fcac885c3040 ChangeLog 432
MD5 8ce72e4001839fb39f9d3b0597e681b8 files/digest-grsec-sources-2.4.21.1.9.11 219
MD5 a66ec80566f602367995d845a5266ed4 files/digest-grsec-sources-2.4.21.2.0_rc2 221
diff --git a/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.1.9.11 b/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.1.9.11
new file mode 100644
index 000000000000..7a0ae520ba04
--- /dev/null
+++ b/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.1.9.11
@@ -0,0 +1,3 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 5fd123c640943fd39338853d6523921a grsecurity-1.9.11-2.4.21.patch 513448
+MD5 b894ea4b1abd6544a25181cd9371c10a grsecurity-1.9.11-2.4.21.patch.sign 189
diff --git a/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.2.0_rc2 b/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.2.0_rc2
new file mode 100644
index 000000000000..7411babc9c36
--- /dev/null
+++ b/sys-kernel/grsec-sources/files/digest-grsec-sources-2.4.21.2.0_rc2
@@ -0,0 +1,3 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 b66f9372769ce59aa7a48fa5a1e750cd grsecurity-2.0-rc2-2.4.21.patch 548888
+MD5 cab2586644d46c2a722b26e039800b52 grsecurity-2.0-rc2-2.4.21.patch.sign 189
diff --git a/sys-kernel/grsec-sources/grsec-sources-2.4.21.1.9.11.ebuild b/sys-kernel/grsec-sources/grsec-sources-2.4.21.1.9.11.ebuild
new file mode 100644
index 000000000000..438e34505081
--- /dev/null
+++ b/sys-kernel/grsec-sources/grsec-sources-2.4.21.1.9.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/grsec-sources/grsec-sources-2.4.21.1.9.11.ebuild,v 1.1 2003/08/14 21:47:23 solar Exp $
+
+# Documentation on the patch contained in this kernel will be installed someday
+
+ETYPE="sources"
+IUSE=""
+
+inherit eutils
+inherit kernel
+
+[ "$OKV" == "" ] && OKV="2.4.21"
+
+PATCH_BASE="${PV/${OKV}./}"
+PATCH_BASE=${PATCH_BASE/_/-}
+EXTRAVERSION="-grsec-${PATCH_BASE}"
+KV=${OKV}${EXTRAVERSION}
+
+###################
+DESCRIPTION="Vanilla sources of the linux kernel with the grsecurity ${PATCH_BASE} patch"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 \
+ http://grsecurity.net/grsecurity-${PATCH_BASE}-${OKV}.patch \
+ http://grsecurity.net/grsecurity-${PATCH_BASE}-${OKV}.patch.sign"
+HOMEPAGE="http://www.kernel.org/ http://www.grsecuirty.net"
+[ ${PATCH_BASE/.*/} == 1 ] && KEYWORDS="x86" || KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+SLOT="${OKV}"
+S=${WORKDIR}/linux-${KV}
+###################
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2 || die "Unable to unpack the kernel"
+ mv linux-${OKV} linux-${KV} || die "Unable to move the kernel"
+ cd linux-${KV} || die "Unable to cd into the kernel source tree"
+ if [ -f "${DISTDIR}/grsecurity-${PATCH_BASE}-${OKV}.patch" ]; then
+ ebegin "Patching the kernel with the grsecurity-${PATCH_BASE}-${OKV} patch"
+ cat ${DISTDIR}/grsecurity-${PATCH_BASE}-${OKV}.patch | patch -p 1
+ eend $?
+ else
+ die "Unable to the kernel patch"
+ fi
+
+ mkdir -p docs
+ touch docs/patches.txt
+
+ kernel_universal_unpack
+ # kernel_src_unpack
+}
+
+#src_install() {
+# kernel_src_install
+#}
diff --git a/sys-kernel/grsec-sources/grsec-sources-2.4.21.2.0_rc2.ebuild b/sys-kernel/grsec-sources/grsec-sources-2.4.21.2.0_rc2.ebuild
new file mode 100644
index 000000000000..6293a217d323
--- /dev/null
+++ b/sys-kernel/grsec-sources/grsec-sources-2.4.21.2.0_rc2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/grsec-sources/grsec-sources-2.4.21.2.0_rc2.ebuild,v 1.1 2003/08/14 21:47:23 solar Exp $
+
+# Documentation on the patch contained in this kernel will be installed someday
+
+ETYPE="sources"
+IUSE=""
+
+inherit eutils
+inherit kernel
+
+[ "$OKV" == "" ] && OKV="2.4.21"
+
+PATCH_BASE="${PV/${OKV}./}"
+PATCH_BASE=${PATCH_BASE/_/-}
+EXTRAVERSION="-grsec-${PATCH_BASE}"
+KV=${OKV}${EXTRAVERSION}
+
+###################
+DESCRIPTION="Vanilla sources of the linux kernel with the grsecurity ${PATCH_BASE} patch"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 \
+ http://grsecurity.net/grsecurity-${PATCH_BASE}-${OKV}.patch \
+ http://grsecurity.net/grsecurity-${PATCH_BASE}-${OKV}.patch.sign"
+HOMEPAGE="http://www.kernel.org/ http://www.grsecuirty.net"
+[ ${PATCH_BASE/.*/} == 1 ] && KEYWORDS="x86" || KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+SLOT="${OKV}"
+S=${WORKDIR}/linux-${KV}
+###################
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2 || die "Unable to unpack the kernel"
+ mv linux-${OKV} linux-${KV} || die "Unable to move the kernel"
+ cd linux-${KV} || die "Unable to cd into the kernel source tree"
+ if [ -f "${DISTDIR}/grsecurity-${PATCH_BASE}-${OKV}.patch" ]; then
+ ebegin "Patching the kernel with the grsecurity-${PATCH_BASE}-${OKV} patch"
+ cat ${DISTDIR}/grsecurity-${PATCH_BASE}-${OKV}.patch | patch -p 1
+ eend $?
+ else
+ die "Unable to the kernel patch"
+ fi
+
+ mkdir -p docs
+ touch docs/patches.txt
+
+ kernel_universal_unpack
+ # kernel_src_unpack
+}
+
+#src_install() {
+# kernel_src_install
+#}
diff --git a/sys-kernel/grsec-sources/metadata.xml b/sys-kernel/grsec-sources/metadata.xml
new file mode 100644
index 000000000000..1fb01966f3ae
--- /dev/null
+++ b/sys-kernel/grsec-sources/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription>Vanilla sources of the linux kernel with the grsecurity patch</longdescription>
+</pkgmetadata>