summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2008-09-08 13:40:59 +0000
committerMike Pagano <mpagano@gentoo.org>2008-09-08 13:40:59 +0000
commit3e30fb1c3301e7d6a815dca4ca3a246c8355da7f (patch)
treec08439da7d1b2300e030e4942a276e1e849c68d3 /sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild
parentSparc stable, Bug #237048. (diff)
downloadhistorical-3e30fb1c3301e7d6a815dca4ca3a246c8355da7f.tar.gz
historical-3e30fb1c3301e7d6a815dca4ca3a246c8355da7f.tar.bz2
historical-3e30fb1c3301e7d6a815dca4ca3a246c8355da7f.zip
Version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc5 i686
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild b/sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild
new file mode 100644
index 000000000000..47e818580605
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.26.4.ebuild,v 1.1 2008/09/08 13:40:59 mpagano Exp $
+
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make mandocs || die "make mandocs failed"
+
+ if use html; then
+ make htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}