summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-09-01 16:27:56 +0000
committerAlex Alexander <wired@gentoo.org>2010-09-01 16:27:56 +0000
commit74a7af82361bd4bec2a02738b7511b4e19019b8a (patch)
tree973fdcf70ff7953406ed6ed65188e71da8d974b8 /sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild
parentVersion bump. (diff)
downloadhistorical-74a7af82361bd4bec2a02738b7511b4e19019b8a.tar.gz
historical-74a7af82361bd4bec2a02738b7511b4e19019b8a.tar.bz2
historical-74a7af82361bd4bec2a02738b7511b4e19019b8a.zip
new ebuilds for pf-kernel
Package-Manager: portage-2.2_rc72/cvs/Linux x86_64
Diffstat (limited to 'sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild')
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild
new file mode 100644
index 000000000000..3967682b10a1
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."