summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
commitc3d2cbe0c97dcd8af8069b0f9ad9681fcfc620aa (patch)
treed7a33afb57336367586aa12d8e3ad6134c9d5423 /sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild
parentminor fix in the r5 patch (diff)
downloadhistorical-c3d2cbe0c97dcd8af8069b0f9ad9681fcfc620aa.tar.gz
historical-c3d2cbe0c97dcd8af8069b0f9ad9681fcfc620aa.tar.bz2
historical-c3d2cbe0c97dcd8af8069b0f9ad9681fcfc620aa.zip
All version setting for kernels is now handled by ebuilds on an individual basis, there were only about 15 which were doing none of it before, so this way we are consistent, the eclass will now simply utilize the variables as they are set in the kernel ebuilds.
Diffstat (limited to 'sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild')
-rw-r--r--sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild b/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild
index d98608ca0f15..375e3384fd54 100644
--- a/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild
+++ b/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild,v 1.4 2003/03/24 23:34:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r8.ebuild,v 1.5 2003/11/20 07:43:38 lostlogic Exp $
IUSE=""
@@ -8,6 +8,12 @@ ETYPE="sources"
inherit kernel
# OKV=original kernel version, KV=patched kernel version. They can be the same.
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
MY_R=`echo $PR | sed "s:r:ben:g"`