summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevyn Shortell <trance@gentoo.org>2002-11-08 11:10:33 +0000
committerKevyn Shortell <trance@gentoo.org>2002-11-08 11:10:33 +0000
commite6bb51a52c4b9bb8885d878ebecddcfb62b258a2 (patch)
tree85aeb333f8845be1acad6d9ffd9798f256555ffb /sys-kernel/ppc-sources-dev
parentupdated to 2.4.20 kernel (diff)
downloadhistorical-e6bb51a52c4b9bb8885d878ebecddcfb62b258a2.tar.gz
historical-e6bb51a52c4b9bb8885d878ebecddcfb62b258a2.tar.bz2
historical-e6bb51a52c4b9bb8885d878ebecddcfb62b258a2.zip
updated to 2.4.20 kernel
Diffstat (limited to 'sys-kernel/ppc-sources-dev')
-rw-r--r--sys-kernel/ppc-sources-dev/ppc-sources-dev-2.4.20.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/sys-kernel/ppc-sources-dev/ppc-sources-dev-2.4.20.ebuild b/sys-kernel/ppc-sources-dev/ppc-sources-dev-2.4.20.ebuild
new file mode 100644
index 000000000000..c5a51bfed801
--- /dev/null
+++ b/sys-kernel/ppc-sources-dev/ppc-sources-dev-2.4.20.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Id: ppc-sources-dev-2.4.20.ebuild,v 1.1 2002/11/08 11:10:33 trance Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PVR}
+KV=2.4.20-r8
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.20-pre1-benh
+# latest SunGEM driver with ibook fixes
+# Ani Joshi's rivafb bigendian fixes from YDL
+
+
+DESCRIPTION="Full developmental sources for the Gentoo Linux PPC kernel - Experimental!"
+SRC_URI="http://www.penguinppc.org/~kevyn/kernels/gentoo/linux-${KV}.tar.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -x86 -sparc -sparc64"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${KV}.tar.bz2
+ cd ${S}
+ pwd
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+
+ einfo "* Warning * - This is an experimental kernel to test features"
+ einfo " before they make it to ppc-sources. This is a use at your own"
+ einfo " risk kernel for the devs and tester to try."
+ einfo " If it eats your computer, You have been warned. =)"
+}