summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-02-11 01:00:59 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-02-11 01:00:59 +0000
commit21207f274b3d9293afccb3f6f188576693c742c0 (patch)
treea018bf7be8ff9e7234d0a6bfa2e0833db8ab7e0a /sys-kernel
parentfixing Manifest (diff)
downloadhistorical-21207f274b3d9293afccb3f6f188576693c742c0.tar.gz
historical-21207f274b3d9293afccb3f6f188576693c742c0.tar.bz2
historical-21207f274b3d9293afccb3f6f188576693c742c0.zip
I'm dumb, forgot a patch for these sources
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mips-prepatch-sources/Manifest1
-rw-r--r--sys-kernel/mips-prepatch-sources/files/mipscvs-2.4.25-pre6-makefile-fix.patch38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/mips-prepatch-sources/Manifest b/sys-kernel/mips-prepatch-sources/Manifest
index 5d634b383a66..8313d00fc2d5 100644
--- a/sys-kernel/mips-prepatch-sources/Manifest
+++ b/sys-kernel/mips-prepatch-sources/Manifest
@@ -3,3 +3,4 @@ MD5 0bfb6b59036d1fe3e8075bc8879e772b metadata.xml 412
MD5 b6e6b794c36f3011a2aac836e2138209 mips-prepatch-sources-2.4.25_pre6.ebuild 2148
MD5 d41d8cd98f00b204e9800998ecf8427e files/.keep 0
MD5 1646cb074c99365f653d5db9416625dc files/digest-mips-prepatch-sources-2.4.25_pre6 290
+MD5 1f2d806ba24602d1a46129700e8fcc5d files/mipscvs-2.4.25-pre6-makefile-fix.patch 1513
diff --git a/sys-kernel/mips-prepatch-sources/files/mipscvs-2.4.25-pre6-makefile-fix.patch b/sys-kernel/mips-prepatch-sources/files/mipscvs-2.4.25-pre6-makefile-fix.patch
new file mode 100644
index 000000000000..2a384f599669
--- /dev/null
+++ b/sys-kernel/mips-prepatch-sources/files/mipscvs-2.4.25-pre6-makefile-fix.patch
@@ -0,0 +1,38 @@
+--- arch/mips64/Makefile.orig 2004-02-05 02:28:01.961823000 -0500
++++ arch/mips64/Makefile 2004-02-05 02:28:59.251823000 -0500
+@@ -26,6 +26,9 @@ ifdef CONFIG_CROSSCOMPILE
+ CROSS_COMPILE = $(tool-prefix)
+ endif
+
++check_gcc = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
++check_gas = $(shell if $(CC) $(1) -Wa,-Z -c -o /dev/null -xassembler /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
++
+ #
+ # The ELF GCC uses -G 0 -mabicalls -fpic as default. We don't need PIC
+ # code in the kernel since it only slows down the whole thing. For the
+@@ -49,9 +52,6 @@ GCCFLAGS += -mno-sched-prolog -fno-omit-
+ endif
+ endif
+
+-check_gcc = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
+-check_gas = $(shell if $(CC) $(1) -Wa,-Z -c -o /dev/null -xassembler /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
+-
+ #
+ # Use: $(call set_gccflags,<cpu0>,<isa0>,<cpu1>,<isa1>)
+ #
+@@ -334,7 +334,7 @@ endif
+ # convert to ECOFF using elf2ecoff.
+ #
+ ifdef CONFIG_BOOT_ELF32
+-GCCFLAGS += -Wa,-32 $(call check_gas,-Wa$(comma)-mgp64,)
++GCCFLAGS += -Wa,-mabi=o64 $(call check_gas,-Wa$(comma)-mgp64,)
+ LINKFLAGS += -T arch/mips64/ld.script.elf32
+ endif
+ #
+@@ -402,5 +402,6 @@ archmrproper:
+ archdep:
+ if [ ! -f $(TOPDIR)/include/asm-$(ARCH)/offset.h ]; then \
+ touch $(TOPDIR)/include/asm-$(ARCH)/offset.h; \
++ $(MAKE) -C arch/mips/tools clean; \
+ fi;
+ @$(MAKEBOOT) dep