summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-20 23:12:12 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-20 23:12:12 +0000
commita570810697aa06d61b51b852f875a70f06580510 (patch)
treeabbc36b371526ab5054690fd95fbf96ba28bfb3a /sys-kernel
parentnuname patch is only applied for non-build situations now (diff)
downloadhistorical-a570810697aa06d61b51b852f875a70f06580510.tar.gz
historical-a570810697aa06d61b51b852f875a70f06580510.tar.bz2
historical-a570810697aa06d61b51b852f875a70f06580510.zip
new headers to fix iptables compile problem
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild12
-rw-r--r--sys-kernel/linux-sources/ChangeLog10
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild12
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.18.ebuild11
4 files changed, 39 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild
index 4465d1607c4c..a267f1188318 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild,v 1.3 2002/03/12 22:19:31 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r5.ebuild,v 1.4 2002/03/20 23:12:12 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -74,17 +74,25 @@ src_unpack() {
rm Makefile.orig
}
+src_compile() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
src_install() {
if [ "$PN" = "linux-sources" ]
then
dodir /usr/src
- cd ${S}
echo ">>> Copying sources..."
mv ${WORKDIR}/* ${D}/usr/src
else
#linux-headers
dodir /usr/include/linux
cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
dodir /usr/include/asm
cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
fi
diff --git a/sys-kernel/linux-sources/ChangeLog b/sys-kernel/linux-sources/ChangeLog
index 1c54a0970666..8c0100fe5c7e 100644
--- a/sys-kernel/linux-sources/ChangeLog
+++ b/sys-kernel/linux-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/linux-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/ChangeLog,v 1.6 2002/03/12 18:22:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/ChangeLog,v 1.7 2002/03/20 23:12:12 drobbins Exp $
+
+*linux-sources-2.4.17-r5 (20 Mar 2002)
+*linux-sources-2.4.18 (20 Mar 2002)
+
+ 20 Mar 2002; Daniel Robbins <drobbins@gentoo.org>: We now do a "yes "" | make
+ oldconfig" for linux-headers (in src_compile()) in order to ensure that
+ /usr/include/linux/autoconf.h gets merged, which is required for things such
+ as iptables and likely many other packages. No rev bump.
*linux-sources-2.4.17-r5 (12 Mar 2002)
*linux-sources-2.4.18 (12 Mar 2002)
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
index e123827d0e0e..373b4e757684 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.3 2002/03/12 22:20:55 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.4 2002/03/20 23:12:12 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -74,17 +74,25 @@ src_unpack() {
rm Makefile.orig
}
+src_compile() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
src_install() {
if [ "$PN" = "linux-sources" ]
then
dodir /usr/src
- cd ${S}
echo ">>> Copying sources..."
mv ${WORKDIR}/* ${D}/usr/src
else
#linux-headers
dodir /usr/include/linux
cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
dodir /usr/include/asm
cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
fi
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
index 0f627525d886..f82b16ab79ed 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild,v 1.3 2002/03/12 22:20:55 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild,v 1.4 2002/03/20 23:12:12 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -72,6 +72,14 @@ src_unpack() {
rm Makefile.orig
}
+src_compile() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
src_install() {
if [ "$PN" = "linux-sources" ]
then
@@ -83,6 +91,7 @@ src_install() {
#linux-headers
dodir /usr/include/linux
cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
dodir /usr/include/asm
cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
fi