summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-12 03:16:09 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-12 03:16:09 +0000
commitc08790eb020c303e6ae3f7cdacfb95328e535cbd (patch)
treefd262bb8c5c6c2db3e385b50c2a2bbbca6242b07 /sys-kernel
parentfilter out -fPIC (diff)
downloadhistorical-c08790eb020c303e6ae3f7cdacfb95328e535cbd.tar.gz
historical-c08790eb020c303e6ae3f7cdacfb95328e535cbd.tar.bz2
historical-c08790eb020c303e6ae3f7cdacfb95328e535cbd.zip
if this breaks, warn me.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog22
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.12
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1.ebuild91
3 files changed, 111 insertions, 4 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 5d13fdb9298e..7a0038bebc0c 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,12 +1,26 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.36 2003/01/08 02:04:35 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.37 2003/01/12 03:16:09 lostlogic Exp $
TODO before gentoo-sources-2.4.20-r1:
* Documentation
- * Test away
- * USAGI patch from mattjf
- * Whatever else I'm forgetting
+
+*lolo-sources-2.4.20.1 (10 Jan 2003)
+ Doing things a littl different this time... people can just
+ keep following lolo-sources and will get the identical
+ as gentoo-sources from the final versions of lolo-sources,
+ except for documentation updates.
+
+ Changes from _rc3:
+ * Got a bunch of testing. Apparently some SCSI+Firewire
+ issues, but I'm not sure if they are isolated to this
+ patchset or if they are 2.4.20 generic problems.
+ * Ext3 data=journal fix.
+ * Add an update for the aic7xx controller
+ * Resync with iptables again.
+ * Add one big defconfig patch to make a nicer default for
+ gentoo users.
+ * Drop all defconfig changes from i386 in patches
*lolo-sources-2.4.20.1_rc3 (07 Jan 2003)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1
new file mode 100644
index 000000000000..542f13b99e8e
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 c709f3940239aa8d9a826d28c7148836 patches-2.4.20-lolo-r1.tar.bz2 3034815
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1.ebuild
new file mode 100644
index 000000000000..184b86ac8230
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1.ebuild,v 1.1 2003/01/12 03:16:09 lostlogic Exp $
+
+IUSE="build crypt xfs"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ # This is the non-ratified xfs USE flag, enables XFS which is not
+ # patched by default because it can cause problems with JFS's
+ # journals.
+ if [ -z "`use xfs`" ]; then
+ einfo "No XFS support, is this on purpose?"
+ for file in 79*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Enabling XFS patch, are you sure you want this?"
+ fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+ ewarn "Known bug: Firewire + Hotplug + SCSI may cause trouble"
+ [ `use xfs` ] && ewarn "XFS patches enabled, this may cause JFS problems" || \
+ einfo "XFS not enabled, is that on purpose? JFS users beware of XFS."
+
+}