summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-22 07:07:34 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-22 07:07:34 +0000
commitc861e387fbd4c1f4f08cd635d5303cb6da9f4990 (patch)
tree1a6cc7c8b73052ac2ebcb6858b1eaa1e3c6cc651 /sys-kernel
parentminor version bump (fixes a gcc3.2 issue) (diff)
downloadhistorical-c861e387fbd4c1f4f08cd635d5303cb6da9f4990.tar.gz
historical-c861e387fbd4c1f4f08cd635d5303cb6da9f4990.tar.bz2
historical-c861e387fbd4c1f4f08cd635d5303cb6da9f4990.zip
New kernel ebuild system, check changelog
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog14
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre32
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre3.ebuild48
3 files changed, 63 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index e4532b2c8f08..688090634a07 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.8 2002/09/21 22:32:58 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.9 2002/09/22 07:07:34 lostlogic Exp $
+
+*lolo-sources-2.4.19.10_pre3 (21 Sep 2002)
+
+ 21 Sep 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.19.10_pre3.ebuild:
+
+ New this version:
+ - Add futexes support
+ - Add imon support
+ - Optional ACPI patch just set USE="acpi4linux"
+ - Redone ebuild setup now we have an eclass for these things
+ - Add support for KERNEL_EXCLUDE
+ - Rename some patches to better names for use with KERNEL_EXCLUDE
*lolo-sources-2.4.19.10_pre2 (21 Sep 2002)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre3 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre3
new file mode 100644
index 000000000000..58012bc77485
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre3
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 ccaa674a06eae3fa16d4bb3b5212111b patches-2.4.19-lolo-r10_pre3.tar.bz2 1843046
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre3.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre3.ebuild
new file mode 100644
index 000000000000..e240a7c940c9
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre3.ebuild,v 1.1 2002/09/22 07:07:34 lostlogic Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flags acpi4linux and
+# ngpt which are patches that are removed by default, but which you can
+# use if you choose to with these use variables.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+#Documentation on the patches contained in this kernel will be installed
+#to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}