summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-06-22 20:48:02 +0000
committerMichael Imhof <tantive@gentoo.org>2003-06-22 20:48:02 +0000
commitd3131703889233eebb1371a48c19dd66e237ea54 (patch)
treedeaf1facad8c153fcd6d7ce095c7616fcceeeac1 /sys-kernel
parentVersion bump (diff)
downloadhistorical-d3131703889233eebb1371a48c19dd66e237ea54.tar.gz
historical-d3131703889233eebb1371a48c19dd66e237ea54.tar.bz2
historical-d3131703889233eebb1371a48c19dd66e237ea54.zip
Version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/Manifest4
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.212
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.21.ebuild106
3 files changed, 110 insertions, 2 deletions
diff --git a/sys-kernel/openmosix-sources/Manifest b/sys-kernel/openmosix-sources/Manifest
index d005257b294b..fe6872155924 100644
--- a/sys-kernel/openmosix-sources/Manifest
+++ b/sys-kernel/openmosix-sources/Manifest
@@ -1,11 +1,11 @@
-MD5 2ecf5b318c3eaa30e740c781b3c00d1a ChangeLog 1130
+MD5 89be188b7a7dbe55f25c85d013b4488f ChangeLog 1289
MD5 139536498ac2981d424ae1628d0935fe openmosix-sources-2.4.20-r1.ebuild 3318
MD5 5cd09b3b7f14b5e7e81fea3d0f6c0e26 openmosix-sources-2.4.20-r2.ebuild 3340
MD5 9f1f6507b5b24fe752321906f4835a3d openmosix-sources-2.4.20-r3.ebuild 3198
MD5 47b7798301ac13c745649ca70e6eed67 openmosix-sources-2.4.20-r4.ebuild 3355
MD5 3eec695f0481b07db403de0e580062eb openmosix-sources-2.4.20-r5.ebuild 3197
MD5 2baf3a70602d45cf08b466989175cb5a openmosix-sources-2.4.20-r6.ebuild 3198
-MD5 bac6911fc91c5e4759022b529cdb050b openmosix-sources-2.4.21.ebuild 3201
+MD5 433f31a4ff1b72a6eabe1ccbd40a3e86 openmosix-sources-2.4.21.ebuild 3199
MD5 41b8fa1f0e2e59514496f8f5d52bcd75 files/digest-openmosix-sources-2.4.20-r1 154
MD5 4843f8c1a5a7d5a7f0f2b37038cab7b6 files/digest-openmosix-sources-2.4.20-r2 154
MD5 32f9a2d3d0d7c57a50c7a055031a72f4 files/digest-openmosix-sources-2.4.20-r3 133
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.21 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.21
new file mode 100644
index 000000000000..a520ef687ffa
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.21
@@ -0,0 +1,2 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 c0f06cde9049b2e17fbc286532dbb2d4 openMosix-2.4.21-1.bz2 276962
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.21.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.21.ebuild
new file mode 100644
index 000000000000..2a128fa767f2
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.21.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.21.ebuild,v 1.1 2003/06/22 20:47:47 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.21
+[ "${PR}" == "r0" ] && KV=${OKV}-openmosix || KV=${OKV}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.21, plus:
+# 2.4.21 openmosix-2.4.21-1
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 mirror://sourceforge/openmosix/openMosix-2.4.21-1.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/openMosix-2.4.21-1.bz2 | bzip2 -d | patch -p1 || die
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+# rm Makefile~
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R root:root *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}