summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-20 07:39:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-20 07:39:37 +0000
commit3ccb362033c33c36c205ca79e3fbdbe02e4ff454 (patch)
tree174ba949b1b35332e172147d172b117d37719ed4 /sys-libs/cracklib/cracklib-2.8.9-r1.ebuild
parentalpha/hppa stable (diff)
downloadhistorical-3ccb362033c33c36c205ca79e3fbdbe02e4ff454.tar.gz
historical-3ccb362033c33c36c205ca79e3fbdbe02e4ff454.tar.bz2
historical-3ccb362033c33c36c205ca79e3fbdbe02e4ff454.zip
Fix from upstream for header leakage #142765 by Ming Zhao.
Package-Manager: portage-2.1.1_pre5-r2
Diffstat (limited to 'sys-libs/cracklib/cracklib-2.8.9-r1.ebuild')
-rw-r--r--sys-libs/cracklib/cracklib-2.8.9-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-libs/cracklib/cracklib-2.8.9-r1.ebuild b/sys-libs/cracklib/cracklib-2.8.9-r1.ebuild
new file mode 100644
index 000000000000..733b0bb8b5e6
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.8.9-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.9-r1.ebuild,v 1.1 2006/08/20 07:39:37 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="CRACKLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls python"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-findpw.patch #142765
+}
+
+src_compile() {
+ econf \
+ --with-default-dict='$(libdir)/cracklib_dict' \
+ $(use_enable nls) \
+ $(use_with python) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ rm -r "${D}"/usr/share/cracklib
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "could not move shared"
+ gen_usr_ldscript libcrack.so
+
+ echo -n "Generating cracklib dicts ... "
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die "word dict"
+ tc-is-cross-compiler \
+ || export PATH=${D}/usr/sbin:${PATH} LD_LIBRARY_PATH=${D}/$(get_libdir)
+ cracklib-format dicts/cracklib-small \
+ | cracklib-packer "${D}"/usr/$(get_libdir)/cracklib_dict \
+ || die "couldnt create dict"
+
+ dodoc AUTHORS ChangeLog NEWS README*
+}