summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-21 11:08:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-21 11:08:39 +0000
commitecc761f03bf8f718688b048fba1ad2bb4bd5c488 (patch)
tree0ac95ad81a98a44fc262638ae06d2ebe1096226f /sys-libs/db/db-4.0.14-r2.ebuild
parentcrucial fix to all ebuilds db-3 or newer for bad symlinks in /usr/lib and /us... (diff)
downloadhistorical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.tar.gz
historical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.tar.bz2
historical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.zip
crucial fix to all ebuilds db-3 or newer for bad symlinks in /usr/lib and /usr/include, code is now in db.eclass
Diffstat (limited to 'sys-libs/db/db-4.0.14-r2.ebuild')
-rw-r--r--sys-libs/db/db-4.0.14-r2.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/sys-libs/db/db-4.0.14-r2.ebuild b/sys-libs/db/db-4.0.14-r2.ebuild
new file mode 100644
index 000000000000..379263f88515
--- /dev/null
+++ b/sys-libs/db/db-4.0.14-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.1 2003/08/21 11:08:36 robbat2 Exp $
+
+IUSE="tcltk java doc"
+
+inherit eutils
+inherit db
+
+S="${WORKDIR}/${P}/build_unix"
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4"
+LICENSE="DB"
+KEYWORDS="~x86"
+
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ cd ${WORKDIR}/${P}; epatch ${FILESDIR}/${P}-fix-dep-link.patch
+}
+
+src_compile() {
+
+ local myconf=
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
+
+ if use java && [ -n "${JAVAC}" ]; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --with-uniquename \
+ ${myconf} || die
+
+# disable posix mutexes as they are not available in linuxthreads from
+# the standard profile and they should be autodetected if available
+#
+# --enable-posixmutexes \
+
+ emake || make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}