summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-10 02:31:27 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-10 02:31:27 +0000
commit0597a321bfe98cfa9cfc14a62fc95759bbed6a71 (patch)
treee59e96454a8a9614d8e43b43fb2c6ebcbc76a3d2 /sys-libs/detect
parentstable on ppc64, bug #66251 (diff)
downloadhistorical-0597a321bfe98cfa9cfc14a62fc95759bbed6a71.tar.gz
historical-0597a321bfe98cfa9cfc14a62fc95759bbed6a71.tar.bz2
historical-0597a321bfe98cfa9cfc14a62fc95759bbed6a71.zip
clean up ebuild to fix #47472
Diffstat (limited to 'sys-libs/detect')
-rw-r--r--sys-libs/detect/Manifest10
-rw-r--r--sys-libs/detect/detect-0.9.72.ebuild31
2 files changed, 22 insertions, 19 deletions
diff --git a/sys-libs/detect/Manifest b/sys-libs/detect/Manifest
index c45d012ad441..f76e2a598a8a 100644
--- a/sys-libs/detect/Manifest
+++ b/sys-libs/detect/Manifest
@@ -2,13 +2,13 @@
Hash: SHA1
MD5 add5ba23c1692923c79ecaf27bfe3411 ChangeLog 560
-MD5 8308205d41ac2bfa210d28cbf2da0ddc detect-0.9.72.ebuild 990
+MD5 086ace929b371946e01cf28457492d93 detect-0.9.72.ebuild 976
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 8861af0d18236fbf10c7754660853ed1 files/digest-detect-0.9.72 140
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.5 (GNU/Linux)
+Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBKr90I1lqEGTUzyQRAuiRAJ9rAtY+eFSWmNpTvTOjxncZn0nSfwCfXmzC
-qClVysMSwkRFfrdGoFQLqwQ=
-=2e1p
+iD8DBQFBaJ8THTu7gpaalycRAmFHAKCVYyOmcLiZp+l83Y/6R37fnt+mFwCbBWHo
+4daEsn4uVcJaA10mI3nfEF0=
+=oPOY
-----END PGP SIGNATURE-----
diff --git a/sys-libs/detect/detect-0.9.72.ebuild b/sys-libs/detect/detect-0.9.72.ebuild
index 64a847722af9..e5ac476bf7dd 100644
--- a/sys-libs/detect/detect-0.9.72.ebuild
+++ b/sys-libs/detect/detect-0.9.72.ebuild
@@ -1,38 +1,41 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/detect/detect-0.9.72.ebuild,v 1.8 2004/08/24 04:09:09 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/detect/detect-0.9.72.ebuild,v 1.9 2004/10/10 02:31:27 vapier Exp $
-DESCRIPTION="Detect is a library for automatic hardware detection."
+inherit eutils
+
+DESCRIPTION="library for automatic hardware detection"
HOMEPAGE="http://www.mandrakelinux.com/harddrake/index.php"
SRC_URI="mirror://debian/pool/main/d/detect/${P//-/_}.orig.tar.gz
mirror://debian/pool/main/d/detect/${P//-/_}-6.1.diff.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+
DEPEND="virtual/libc"
+
S="${WORKDIR}/${PN}"
src_unpack() {
- unpack ${P//-/_}.orig.tar.gz
- cd $S
- gunzip -c ${DISTDIR}/${P//-/_}-6.1.diff.gz | patch -p1
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P//-/_}-6.1.diff
+ chmod a+rx configure config.sub config.guess
+ sed -i '/include.*genhd\.h/s:.*::' src/{detect.h,disk.c}
}
src_compile() {
- ./autogen.sh \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf --with-kernel-source="${ROOT}/usr" || die
emake || die
}
-src_install () {
- #make DESTDIR=${D} install || die
+src_install() {
make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
+ DESTDIR="${D}" \
+ localedir="${D}/usr/share/locale" \
+ gnulocaledir="${D}/usr/share/locale" \
install || die
}