summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-09 19:35:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-09 19:35:40 +0000
commit1b8f729ab81b56dba1f7bed03036b01d2cb57536 (patch)
treed0aad7e25d3f1907e49a8d5d6bba7f550576a012 /sys-libs/freeipmi
parentRemove exec bit from the init scripts (part 1: commit removal). (diff)
downloadhistorical-1b8f729ab81b56dba1f7bed03036b01d2cb57536.tar.gz
historical-1b8f729ab81b56dba1f7bed03036b01d2cb57536.tar.bz2
historical-1b8f729ab81b56dba1f7bed03036b01d2cb57536.zip
Remove exec bit from the init scripts (part 2: commit non-exec scripts).
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/freeipmi')
-rw-r--r--sys-libs/freeipmi/Manifest8
-rw-r--r--sys-libs/freeipmi/files/bmc-watchdog.initd27
-rw-r--r--sys-libs/freeipmi/files/ipmidetectd.initd27
3 files changed, 59 insertions, 3 deletions
diff --git a/sys-libs/freeipmi/Manifest b/sys-libs/freeipmi/Manifest
index 3b2eed5040d9..2f4548323cbe 100644
--- a/sys-libs/freeipmi/Manifest
+++ b/sys-libs/freeipmi/Manifest
@@ -2,7 +2,9 @@
Hash: SHA1
AUX bmc-watchdog.confd 1495 RMD160 c7335f914d4a5904a358a5140a3427a43cd75988 SHA1 8faba92b3ec4ed072b85e41e9bb9f82f867aa8fd SHA256 0f9cbe8090523e3fd4df35fb049d38ee696292892542ff6ffe3139e39fb1795e
+AUX bmc-watchdog.initd 824 RMD160 05a18c843c92de4fa79938aaef882b43dfd23274 SHA1 b487327b4219ba948f322a1159677298368719c4 SHA256 02995b82bfaeafb11c9f067dce5bbd23d2adc87e4acf38b41e01f74aee9a6617
AUX freeipmi-0.6.10+glibc-2.8.patch 5362 RMD160 914711231432f91fc03ad229ea8afcd8fb2a9651 SHA1 65f023ed3ded23996b90bd9c6e52ab6772ac6b27 SHA256 d9bc35866e5b48d25261e51c81a1db08044c552b6a2ea8537fbce9ab4b97ebaf
+AUX ipmidetectd.initd 800 RMD160 91f992208e621b2ef47f4b2c5c70a658b6ddc12d SHA1 b9a4bbacd1ab4ec661ff7817b567d37d720f4c8a SHA256 9b142aff8690a97686df5d7ddf6888cd4d68142dba60632345a0decf5ba0aa77
DIST freeipmi-0.6.10.tar.gz 1669900 RMD160 073790a58d1589c1a07dcf73baa6601f4cb1d36f SHA1 1718ae26ec0b5dc093e82ff264b4f97fb753fbb9 SHA256 33c22e46feabe027913b40fd9ff5a8a745ac9b6cf27a6010f0fa801b2a966cdd
DIST freeipmi-0.8.8.tar.gz 2770784 RMD160 3e3e65051b6edcad9a72d5f4a3daa47af35edbcd SHA1 039def2ac44c0cf3e2418232c3c9b8d3e765175b SHA256 176ce440d200f5e57e7ec05b8c648929263f51c776206f8f730eaa7b41d22dd1
EBUILD freeipmi-0.6.10.ebuild 1461 RMD160 f50e8c49c54863f2ed17b92de203669b67106feb SHA1 671eefae36da7f910b95b74575746e57a3e0629e SHA256 4f0d3ed12af58b46420883bda04182b4a5c0801835aaed1cf68b9ba54ac15c7e
@@ -12,7 +14,7 @@ MISC metadata.xml 234 RMD160 6498603a1fe3a96823743847afc906df194bb430 SHA1 5ec76
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
-iEYEARECAAYFAkxgWFoACgkQAiZjviIA2Xh5xwCcDq422d+m/RWwYmKBY0K7GUKL
-nrgAninNj8m5elWTM61/5J1a7OJ4oW7H
-=VK+W
+iEYEARECAAYFAkxgWIoACgkQAiZjviIA2XjpzACgusq2tR6sC0w0blPQeTgjBoCZ
+wgQAn0pJ0YGSTiH3T+lLW2/6cNP0Gdlt
+=EwsA
-----END PGP SIGNATURE-----
diff --git a/sys-libs/freeipmi/files/bmc-watchdog.initd b/sys-libs/freeipmi/files/bmc-watchdog.initd
new file mode 100644
index 000000000000..e1e63515b808
--- /dev/null
+++ b/sys-libs/freeipmi/files/bmc-watchdog.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/files/bmc-watchdog.initd,v 1.3 2010/08/09 19:35:40 flameeyes Exp $
+
+start() {
+ ebegin "Starting bmc-watchdog"
+ if [ -f /var/run/bmc-watchdog.pid ] ; then
+ ewarn "/var/run/bmc-watchdog.pid already exists,"
+ ewarn "removing it but you might want to find out"
+ ewarn "why this happened."
+ rm /var/run/bmc-watchdog.pid
+ fi
+ start-stop-daemon --background --make-pidfile \
+ --start --quiet --exec /usr/sbin/bmc-watchdog \
+ --pidfile /var/run/bmc-watchdog.pid -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bmc-watchdog"
+ start-stop-daemon \
+ --stop --quiet \
+ --pidfile /var/run/bmc-watchdog.pid
+ eend $?
+ rm /var/run/bmc-watchdog.pid
+}
diff --git a/sys-libs/freeipmi/files/ipmidetectd.initd b/sys-libs/freeipmi/files/ipmidetectd.initd
new file mode 100644
index 000000000000..a9b274c91eae
--- /dev/null
+++ b/sys-libs/freeipmi/files/ipmidetectd.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/files/ipmidetectd.initd,v 1.3 2010/08/09 19:35:40 flameeyes Exp $
+
+start() {
+ ebegin "Starting ipmidetectd"
+ if [ -f /var/run/ipmidetectd.pid ] ; then
+ ewarn "/var/run/ipmidetectd.pid already exists,"
+ ewarn "removing it but you might want to find out"
+ ewarn "why this happened."
+ rm /var/run/ipmidetectd.pid
+ fi
+ start-stop-daemon --background --make-pidfile \
+ --start --quiet --exec /usr/sbin/ipmidetectd \
+ --pidfile /var/run/ipmidetectd.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ipmidetectd"
+ start-stop-daemon \
+ --stop --quiet \
+ --pidfile /var/run/ipmidetectd.pid
+ eend $?
+ rm /var/run/ipmidetectd.pid
+}