summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
commit904e21b09341f6332e690183b6eb6f114423af97 (patch)
treeaacb2c2d7fcd4a5b9819c39919cac759e7a3cc2f /sys-libs/glibc/glibc-2.7-r2.ebuild
parentRevision bump to add support for the ia32 USE flag to install a 32-bit Opera ... (diff)
downloadhistorical-904e21b09341f6332e690183b6eb6f114423af97.tar.gz
historical-904e21b09341f6332e690183b6eb6f114423af97.tar.bz2
historical-904e21b09341f6332e690183b6eb6f114423af97.zip
Short circuit header building in pkg testing and ABI recursion.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25 x86_64
Diffstat (limited to 'sys-libs/glibc/glibc-2.7-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.7-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.7-r2.ebuild b/sys-libs/glibc/glibc-2.7-r2.ebuild
index 66fc9106acbe..cbaefce4196e 100644
--- a/sys-libs/glibc/glibc-2.7-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7-r2.ebuild,v 1.9 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7-r2.ebuild,v 1.10 2008/06/23 01:39:12 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -265,6 +265,9 @@ fix_lib64_symlinks() {
}
pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
# PPC64+others may want to eventually be added to this logic if they
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
@@ -307,6 +310,9 @@ pkg_preinst() {
}
pkg_postinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
if ! tc-is-cross-compiler && [[ -x ${ROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
"${ROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}"