summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2004-11-25 10:12:03 +0000
committerChristian Parpart <trapni@gentoo.org>2004-11-25 10:12:03 +0000
commit91e6597426e917980b0387b6d49d37aa9ef6a2da (patch)
tree4dec97ce662999ffe04d14e1292a6747277febbe /sys-libs/libmath++/libmath++-0.0.4.ebuild
parentVersion bump. Closes bug #71922. (diff)
downloadhistorical-91e6597426e917980b0387b6d49d37aa9ef6a2da.tar.gz
historical-91e6597426e917980b0387b6d49d37aa9ef6a2da.tar.bz2
historical-91e6597426e917980b0387b6d49d37aa9ef6a2da.zip
version bump and download URL fixes
Diffstat (limited to 'sys-libs/libmath++/libmath++-0.0.4.ebuild')
-rw-r--r--sys-libs/libmath++/libmath++-0.0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-libs/libmath++/libmath++-0.0.4.ebuild b/sys-libs/libmath++/libmath++-0.0.4.ebuild
new file mode 100644
index 000000000000..03be10a0349b
--- /dev/null
+++ b/sys-libs/libmath++/libmath++-0.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/libmath++-0.0.4.ebuild,v 1.1 2004/11/25 10:12:03 trapni Exp $
+
+DESCRIPTION="template based math library, written in C++, for symbolic and numeric calculus applications"
+HOMEPAGE="http://www.surakware.net/projects/libmath++/index.xml"
+SRC_URI="http://upstream.trapni-akane.org/libmath%2B%2B/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~s390"
+IUSE=""
+
+DEPEND=">=sys-devel/autoconf-2.59-r5
+ >=sys-devel/automake-1.8.5-r1"
+
+RDEPEND=""
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+ autoreconf -v --install
+
+ econf || die "configure failed"
+
+ emake || die "make filed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+}