summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-09-25 14:08:58 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-09-25 14:08:58 +0000
commitcf0732100415d0fa63985f8765fdf12d14315678 (patch)
tree47c947c8e7e7ad676bbdedc2ca794801f9ed998e /sys-libs/lwp/lwp-2.1.ebuild
parentVersion bump in the development series. (diff)
downloadhistorical-cf0732100415d0fa63985f8765fdf12d14315678.tar.gz
historical-cf0732100415d0fa63985f8765fdf12d14315678.tar.bz2
historical-cf0732100415d0fa63985f8765fdf12d14315678.zip
Added lwp 2.1 for coda 6.0.12
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'sys-libs/lwp/lwp-2.1.ebuild')
-rw-r--r--sys-libs/lwp/lwp-2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/lwp/lwp-2.1.ebuild b/sys-libs/lwp/lwp-2.1.ebuild
new file mode 100644
index 000000000000..1e4876c4fa0c
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-2.1.ebuild,v 1.1 2005/09/25 14:08:58 griffon26 Exp $
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/grep
+ sys-apps/sed
+ sys-devel/libtool
+ sys-devel/gcc"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch ${FILESDIR}/lwp-2.0-amd64.patch
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS NEWS PORTING README
+}