summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-01-16 07:30:51 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-01-16 07:30:51 +0000
commit792a2eb6cc5514722ee2ed53d45834a7e949ca0b (patch)
tree38710020853f12d5d316fa72e50405984fff16ee /sys-libs/ncurses/ncurses-5.3-r2.ebuild
parentAdded gnuconfig support for properly detecting mips systems and moved sed-4.0... (diff)
downloadhistorical-792a2eb6cc5514722ee2ed53d45834a7e949ca0b.tar.gz
historical-792a2eb6cc5514722ee2ed53d45834a7e949ca0b.tar.bz2
historical-792a2eb6cc5514722ee2ed53d45834a7e949ca0b.zip
Added gnuconfig support for mips in ncurses-5.3-r2 through -r5 and bumped -r1 back into arm unstable to fix dependency issue.
Diffstat (limited to 'sys-libs/ncurses/ncurses-5.3-r2.ebuild')
-rw-r--r--sys-libs/ncurses/ncurses-5.3-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/ncurses/ncurses-5.3-r2.ebuild b/sys-libs/ncurses/ncurses-5.3-r2.ebuild
index acbdf438be1f..ac8ffb5dd727 100644
--- a/sys-libs/ncurses/ncurses-5.3-r2.ebuild
+++ b/sys-libs/ncurses/ncurses-5.3-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r2.ebuild,v 1.14 2004/01/11 14:47:47 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r2.ebuild,v 1.15 2004/01/16 07:30:51 kumba Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic gnuconfig
filter-flags -fno-exceptions
DESCRIPTION="Linux console display library"
@@ -24,6 +24,9 @@ src_unpack() {
src_compile() {
[ `use debug` ] && myconf="${myconf} --without-debug"
+ # Detect mips systems
+ use mips && gnuconfig_update
+
# From version 5.3, ncurses also build c++ bindings, and as
# we do not have a c++ compiler during bootstrap, disable
# building it. We will rebuild ncurses after gcc's second