summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 01:05:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 01:05:51 +0000
commit59d78ace50f7116190ae756d485464db2b2a5f23 (patch)
tree8f4047ebe6d90a1c42b1073822441f6b5b633180 /sys-libs/uclibc/uclibc-0.9.28.ebuild
parentVersion bump. (diff)
downloadhistorical-59d78ace50f7116190ae756d485464db2b2a5f23.tar.gz
historical-59d78ace50f7116190ae756d485464db2b2a5f23.tar.bz2
historical-59d78ace50f7116190ae756d485464db2b2a5f23.zip
Stabilize, add a few minor bugfixes, and add support for USE=savedconfig.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-libs/uclibc/uclibc-0.9.28.ebuild')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index a9723d1a18ab..fdf90df221ea 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.16 2005/12/29 12:30:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.17 2006/01/27 01:05:51 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -21,7 +21,7 @@ fi
MY_P=uClibc-${PV}
SVN_VER=""
-PATCH_VER="1.2"
+PATCH_VER="1.3"
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="http://www.uclibc.org/"
SRC_URI="http://www.kernel.org/pub/linux/libs/uclibc/${MY_P}.tar.bz2
@@ -37,8 +37,8 @@ LICENSE="LGPL-2"
[[ ${CTARGET} != ${CHOST} ]] \
&& SLOT="${CTARGET}" \
|| SLOT="0"
-KEYWORDS="-* ~arm ~m68k -mips ~ppc sh ~sparc ~x86"
-IUSE="build uclibc-compat debug hardened iconv ipv6 minimal nls pregen userlocales wordexp"
+KEYWORDS="-* arm m68k -mips ppc sh sparc x86"
+IUSE="build uclibc-compat debug hardened iconv ipv6 minimal nls pregen savedconfig userlocales wordexp"
RESTRICT="nostrip"
RDEPEND=""
@@ -320,6 +320,22 @@ src_unpack() {
echo "UCLIBC_BUILD_NOW=n" >> .config
fi
+ # Allow users some custom control over the config
+ if use savedconfig ; then
+ [[ -r .config ]] && rm .config
+ for conf in ${PN}-${PV}-${PR} ${PN}-${PV} ${PN}; do
+ configfile=${ROOT}/etc/${PN}/${CTARGET}/${conf}.config
+ einfo "Checking existence of ${configfile} ..."
+ [[ -r ${configfile} ]] || configfile=/etc/${PN}/${CHOST}/${conf}.config
+ if [[ -r ${configfile} ]] ; then
+ cp "${configfile}" "${S}"/.config
+ einfo "Found your ${configfile} and using it."
+ einfo "Note that this feature is *totally unsupported*."
+ break
+ fi
+ done
+ fi
+
# setup build and run paths
local cross=${CTARGET}-
type -p ${cross}ar > /dev/null || cross=""