summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
commitdc82d217926b16cc855a22bce173bcacababcdb3 (patch)
treeb5458ebdb3b40d35614f81d66c4808b20b0bb654 /sys-libs/uclibc/uclibc-0.9.28.ebuild
parentremoved stale entries for gcl and xfoil (diff)
downloadhistorical-dc82d217926b16cc855a22bce173bcacababcdb3.tar.gz
historical-dc82d217926b16cc855a22bce173bcacababcdb3.tar.bz2
historical-dc82d217926b16cc855a22bce173bcacababcdb3.zip
dont run scanelf when cross-compiling and fix stack_end issues #113343
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sys-libs/uclibc/uclibc-0.9.28.ebuild')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index a39c37b1f806..7ae93cd426f2 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.13 2005/11/25 22:20:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.14 2005/12/01 10:10:12 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -21,7 +21,7 @@ fi
MY_P=uClibc-${PV}
SVN_VER=""
-PATCH_VER="1.1"
+PATCH_VER="1.2"
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="http://www.uclibc.org/"
SRC_URI="http://www.kernel.org/pub/linux/libs/uclibc/${MY_P}.tar.bz2
@@ -213,19 +213,25 @@ src_unpack() {
local moredefs="DL_FINI_CRT_COMPAT"
# We need todo this for a few months. .28 is a major upgrade.
- if ! use uclibc-compat && [[ "$UCLIBC_SCANED_COMPAT" == "" ]]; then
- local fnames=""
- einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
- fnames="$(scanelf -pyqs__uClibc_start_main -F%F#s)"
- if [ "$fnames" == "" ]; then
- einfo "This system is clean."
- einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANED_COMPAT=1"
- moredefs=""
+ # Don't do it from cross-compiling case though
+ if ! use uclibc-compat ; then
+ if [[ -z ${UCLIBC_AND_GLIBC} ]] && [[ -z ${UCLIBC_SCANNED_COMPAT} ]] && \
+ ! just_headers && [[ ${CHOST} == ${CTARGET} ]] ; then
+ local fnames=""
+ einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
+ fnames=$(scanelf -pyqs__uClibc_start_main -F%F#s)
+ if [[ -z ${fnames} ]] ; then
+ einfo "This system is clean."
+ einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANNED_COMPAT=1"
+ moredefs=""
+ else
+ ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
+ ewarn "qfile ${fnames}"
+ echo
+ ewarn "Leaving on ${moredefs}"
+ fi
else
- ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
- ewarn "qfile ${fnames}"
- echo
- ewarn "Leaving on ${moredefs}"
+ moredefs=""
fi
fi
for def in ${moredefs} MALLOC_GLIBC_COMPAT DO_C99_MATH UCLIBC_HAS_{RPC,CTYPE_CHECKED,WCHAR,HEXADECIMAL_FLOATS,GLIBC_CUSTOM_PRINTF,FOPEN_EXCLUSIVE_MODE,GLIBC_CUSTOM_STREAMS,PRINTF_M_SPEC,FTW} ; do