summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-20 00:05:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-20 00:05:36 +0000
commit1556f546b741906b81b2afd1052f53c578412547 (patch)
tree9b5e130a87cdd8e4020a520407a9d0c5086bcb0d /sys-libs
parentMoving licence for package t_coffee. (diff)
downloadhistorical-1556f546b741906b81b2afd1052f53c578412547.tar.gz
historical-1556f546b741906b81b2afd1052f53c578412547.tar.bz2
historical-1556f546b741906b81b2afd1052f53c578412547.zip
update the OABI stuff in src_compile and src_install to handle cross-compilers #109771
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild47
2 files changed, 31 insertions, 24 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 11f7ccad2a81..1a9fe652fbb9 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -129,7 +129,7 @@ MD5 53ca9d018c1156e40ae6b4aecfafc7c1 glibc-2.3.4.20041102-r1.ebuild 34314
MD5 5eeb3fe6a71b64a081e642ffb08c0cbe glibc-2.3.4.20041102-r2.ebuild 41281
MD5 9bc40ac03e72b63652f67be3dcecc184 glibc-2.3.4.20050125-r1.ebuild 39474
MD5 5348d2828d213442a4c0d6e49b0f58be glibc-2.3.5-r1.ebuild 40537
-MD5 b15c1d3425ad2c3a8271d6d73d52b808 glibc-2.3.5-r2.ebuild 38696
+MD5 08437b93ab868fb95412cf2dd658b7e9 glibc-2.3.5-r2.ebuild 38859
MD5 1cb57f1757c26c0e0286cb0ef6c36171 glibc-2.3.5.20050421.ebuild 40152
MD5 48b60115273ba9fa755a6ef94fe8c3b6 glibc-2.3.5.20050722.ebuild 39299
MD5 9c15c32a0bbef91769c4fd0c0d7a66c3 glibc-2.3.5.ebuild 40143
@@ -137,7 +137,7 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDVrRXOpjtAl+gMRURAutlAJ9NSj56PaaZfQaPBSIe31QlvmdFJgCeN3mc
-kw5QyNQL941uFeOdKMvS4as=
-=o4lR
+iD8DBQFDVt/ogIKl8Uu19MoRApZoAJ97iIdLD1CTgqfhsUQfhwxw/4688QCggiwR
+3HnsqWxoYKSh054iVg42+Zc=
+=S9Dh
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index cd32b67cd5c1..a8e983e87b7f 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.18 2005/10/19 21:00:35 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.19 2005/10/20 00:05:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1153,23 +1153,22 @@ src_compile() {
setup_env
if [[ -z ${OABI} ]] ; then
+ local abilist=""
if has_multilib_profile ; then
+ abilist=$(get_install_abis)
+ einfo "Building multilib glibc for ABIs: ${abilist}"
+ elif is_crosscompile || tc-is-cross-compiler ; then
+ abilist=${DEFAULT_ABI}
+ fi
+ if [[ -n ${abilist} ]] ; then
OABI=${ABI}
- einfo "Building multilib glibc for ABIs: $(get_install_abis)"
- for ABI in $(get_install_abis) ; do
+ for ABI in ${abilist} ; do
export ABI
src_compile
done
ABI=${OABI}
unset OABI
return 0
- elif is_crosscompile || tc-is-cross-compiler ; then
- OABI=${ABI}
- export ABI=${DEFAULT_ABI}
- src_compile
- ABI=${OABI}
- unset OABI
- return 0
fi
fi
@@ -1198,16 +1197,24 @@ src_test() {
src_install() {
setup_env
- if [[ -z ${OABI} ]] && has_multilib_profile ; then
- OABI=${ABI}
- einfo "Installing multilib glibc for ABIs: $(get_install_abis)"
- for ABI in $(get_install_abis) ; do
- export ABI
- src_install
- done
- ABI=${OABI}
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] ; then
+ local abilist=""
+ if has_multilib_profile ; then
+ abilist=$(get_install_abis)
+ einfo "Installing multilib glibc for ABIs: ${abilist}"
+ elif is_crosscompile || tc-is-cross-compiler ; then
+ abilist=${DEFAULT_ABI}
+ fi
+ if [[ -n ${abilist} ]] ; then
+ OABI=${ABI}
+ for ABI in ${abilist} ; do
+ export ABI
+ src_install
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
fi
# Handle stupid lib32 BS