summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-28 05:03:16 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-28 05:03:16 +0000
commit39765f8f5976a07372cd9c4ba8a756379d1a5fc4 (patch)
tree432f0ea4473b5b6d5ed5c52a0ca349e79aff9707 /sys-libs
parentAdd python3 support. (diff)
downloadhistorical-39765f8f5976a07372cd9c4ba8a756379d1a5fc4.tar.gz
historical-39765f8f5976a07372cd9c4ba8a756379d1a5fc4.tar.bz2
historical-39765f8f5976a07372cd9c4ba8a756379d1a5fc4.zip
Fix array walking logic with ldsos.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_install.eblit6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index bab218fdb543..e3d149be195c 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,9 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.925 2013/02/12 15:53:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.926 2013/03/28 05:03:16 vapier Exp $
+
+ 28 Mar 2013; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_install.eblit:
+ Fix array walking logic with ldsos.
12 Feb 2013; Jeroen Roovers <jer@gentoo.org> glibc-2.15-r1.ebuild,
glibc-2.15-r2.ebuild:
diff --git a/sys-libs/glibc/files/eblits/src_install.eblit b/sys-libs/glibc/files/eblits/src_install.eblit
index 83fd6a602932..ed6d84c1fc45 100644
--- a/sys-libs/glibc/files/eblits/src_install.eblit
+++ b/sys-libs/glibc/files/eblits/src_install.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.25 2012/11/11 07:24:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.26 2013/03/28 05:03:16 vapier Exp $
toolchain-glibc_src_install() {
local GBUILDDIR
@@ -95,7 +95,7 @@ toolchain-glibc_src_install() {
if [[ ${SYMLINK_LIB} == "yes" ]] && [[ ! -e ${D}/$(alt_prefix)/lib ]] ; then
dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) $(alt_prefix)/lib
fi
- for (( i = 0; i < ${#ldso_abi_list[@]}; ++i )) ; do
+ for (( i = 0; i < ${#ldso_abi_list[@]}; i += 2 )) ; do
ldso_abi=${ldso_abi_list[i]}
has ${ldso_abi} $(get_install_abis) || continue