summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-06 11:44:08 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-06 11:44:08 +0000
commit4face166895a369e9cfac1b05d8163a0df14fa64 (patch)
treeca9189859361194cbf6d5824e6500894ca30d196 /sys-libs
parentFixes bug #84189 (diff)
downloadhistorical-4face166895a369e9cfac1b05d8163a0df14fa64.tar.gz
historical-4face166895a369e9cfac1b05d8163a0df14fa64.tar.bz2
historical-4face166895a369e9cfac1b05d8163a0df14fa64.zip
Fix sparc64 so it can have a 32bit nptl. Made want_nptl only return true for sparc if using v9.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild13
2 files changed, 13 insertions, 8 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 9866322424d8..bb0c051141a9 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -11,7 +11,7 @@ MD5 ab06008394eb7c6aa17a674cae788eef glibc-2.3.4.20041102.ebuild 32888
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 b85c16a0e65a32784335e40fb0edac0e glibc-2.2.5-r10.ebuild 4418
MD5 695f1e83d1cb212d83d97f0d2989cb94 glibc-2.3.4.20050125.ebuild 35240
-MD5 170201ee2f98e28961ed2578c27e5ec1 glibc-2.3.4.20050125-r1.ebuild 37091
+MD5 3cf9805c73f8d8b9e84ba1cbb31897d8 glibc-2.3.4.20050125-r1.ebuild 37188
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
MD5 42af7e35fe2404a49954f91fd1aee891 files/digest-glibc-2.3.3.20040420-r2 312
@@ -145,7 +145,7 @@ MD5 b72e5aca6d834026a6f5fb87623e6fd3 files/2.3.4/host.conf 1302
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCKlAMArHZZzCEUG0RAnT3AJwOorH1INqT47J+Lbb3G+L3l53+swCgiDqN
-xSCXuIXWZtgKnuxkfHv0o0g=
-=b4vN
+iD8DBQFCKu0xArHZZzCEUG0RAixDAKCJ/cYqTXtlDbL1MDhMFSTchSPK8wCeNyqq
+LDlFZnVCxUuVT8JFgcvuXpo=
+=NiT7
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index a35018a83ddd..92083a23a9bd 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.15 2005/03/06 00:34:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.16 2005/03/06 11:44:08 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -301,7 +301,7 @@ toolchain-glibc_src_install() {
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
install_root=${D} \
install || die
- elif use nptlonly ; then
+ else # nptlonly
cd ${WORKDIR}/build-${ABI}-${CTARGET}-nptl
einfo "Installing GLIBC with NPTL..."
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
@@ -602,7 +602,7 @@ setup_flags() {
# Sparc64 Only support...
if has_multilib_profile || [ "${PROFILE_ARCH}" = "sparc64" ] ; then
case ${ABI} in
- default|sparc)
+ default|sparc32)
if is-flag "-mcpu=ultrasparc3"; then
CTARGET_OPT="sparcv9b-unknown-linux-gnu"
else
@@ -718,7 +718,12 @@ want_nptl() {
# Archs that can use NPTL
case $(tc-arch) in
- amd64|ia64|ppc|ppc64|s390|sparc|x86)
+ amd64|ia64|ppc|ppc64|s390|x86)
+ return 0;
+ ;;
+ sparc)
+ # >= v9 is needed for nptl.
+ [[ "${PROFILE_ARCH}" == "sparc32" ]] && return 1
return 0;
;;
esac