summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-12 21:35:07 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-12 21:35:07 +0000
commit6abd910bcaeb17f25ac8b81803b64b508d552946 (patch)
treef570e56532c19a0e5b427c7e2ebc265efe397586 /sys-libs
parentChanged paths from absolute to relative (diff)
downloadhistorical-6abd910bcaeb17f25ac8b81803b64b508d552946.tar.gz
historical-6abd910bcaeb17f25ac8b81803b64b508d552946.tar.bz2
historical-6abd910bcaeb17f25ac8b81803b64b508d552946.zip
*** empty log message ***
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.2.ebuild7
-rw-r--r--sys-libs/gpm/files/gpmInt.h170
-rw-r--r--sys-libs/gpm/gpm-1.19.3.ebuild8
-rw-r--r--sys-libs/ncurses/ncurses-5.1-r1.ebuild9
5 files changed, 189 insertions, 9 deletions
diff --git a/sys-libs/cracklib/cracklib-2.7-r1.ebuild b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
index 7dee7b0e6594..91d728181596 100644
--- a/sys-libs/cracklib/cracklib-2.7-r1.ebuild
+++ b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r1.ebuild,v 1.6 2000/11/07 11:16:08 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r1.ebuild,v 1.7 2000/11/12 21:35:07 achim Exp $
A=cracklib2_2.7.orig.tar.gz
A0=${P}-redhat.patch
@@ -9,7 +9,7 @@ S=${WORKDIR}/cracklib,2.7
DESCRIPTION="Cracklib"
SRC_URI="ftp://ftp.debian.org/debian/dists/potato/main/source/utils/cracklib2_2.7.orig.tar.gz"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND="|| ( sys-libs/glibc-2.1.3-r3 sys-libs/glibc-2.2 )"
RDEPEND=">=sys-libs/glibc-2.1.3
>=sys-apps/bash-2.04"
diff --git a/sys-libs/glibc/glibc-2.2.ebuild b/sys-libs/glibc/glibc-2.2.ebuild
index 812f469612c6..f5cc060a7977 100644
--- a/sys-libs/glibc/glibc-2.2.ebuild
+++ b/sys-libs/glibc/glibc-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.ebuild,v 1.1 2000/11/11 19:01:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.ebuild,v 1.2 2000/11/12 21:30:43 achim Exp $
A="$P.tar.gz glibc-linuxthreads-${PV}.tar.gz"
S=${WORKDIR}/${P}
@@ -23,7 +23,7 @@ src_compile() {
--enable-add-ons=linuxthreads,crypt,localedata \
--disable-profile --prefix=/usr \
--enable-kernel=2.2.17
- try make
+ try make
make check
}
@@ -38,7 +38,10 @@ src_install() {
rm -rf ${D}
mkdir ${D}
dodir /etc/rc.d/init.d
+ export LC_ALL=C
try make install_root=${D} install -C buildhere
+ try make install_root=${D} info -C buildhere
+ try make install_root=${D} localedata/install-locales -C buildhere
try make -C linuxthreads/man
mkdir -p ${D}/usr/man/man3
install -m 0644 linuxthreads/man/*.3thr ${D}/usr/man/man3
diff --git a/sys-libs/gpm/files/gpmInt.h b/sys-libs/gpm/files/gpmInt.h
new file mode 100644
index 000000000000..43d4a845839b
--- /dev/null
+++ b/sys-libs/gpm/files/gpmInt.h
@@ -0,0 +1,170 @@
+/*
+ * gpmInt.h - server-only stuff for gpm-Linux
+ *
+ * Copyright (C) 1994-1999 Alessandro Rubini <rubini@linux.it>
+ * Copyright (C) 1998 Ian Zimmerman <itz@rahul.net>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ ********/
+
+#ifndef _GPMINT_INCLUDED
+#define _GPMINT_INCLUDED
+
+/* $Id: gpmInt.h,v 1.1 2000/11/12 21:35:07 achim Exp $ */
+
+#include <sys/types.h> /* time_t */
+
+#include "gpmCfg.h"
+#include "gpm.h"
+
+#if !defined(__GNUC__)
+# define inline
+#endif
+
+#ifdef DEBUG
+# define inline
+#endif
+
+#ifndef OPEN_MAX
+#define OPEN_MAX 256
+#endif
+
+#include "wd.h" /* when debugging macros */
+
+/*....................................... Strange requests (iff conn->pid==0)*/
+
+#define GPM_REQ_SNAPSHOT 0
+#define GPM_REQ_BUTTONS 1
+#define GPM_REQ_CONFIG 2
+#define GPM_REQ_NOPASTE 3
+
+/*....................................... Structures */
+
+
+/*
+ * and this is the entry in the mouse-type table
+ */
+typedef struct Gpm_Type {
+ char *name;
+ char *desc; /* a descriptive line */
+ char *synonyms; /* extra names (the XFree name etc) as a list */
+ int (*fun)(Gpm_Event *state, unsigned char *data);
+ struct Gpm_Type *(*init)(int fd, unsigned short flags,
+ struct Gpm_Type *type, int argc, char **argv);
+ unsigned short flags;
+ unsigned char proto[4];
+ int packetlen;
+ int howmany; /* howmany bytes to read at a time */
+ int getextra; /* does it get an extra byte? (only mouseman) */
+ int absolute; /* flag indicating absolute pointing device */
+
+ int (*repeat_fun)(Gpm_Event *state, int fd); /* repeat this event into fd */
+ /* itz Mon Jan 11 23:27:54 PST 1999 */
+} Gpm_Type;
+
+#define GPM_EXTRA_MAGIC_1 0xAA
+#define GPM_EXTRA_MAGIC_2 0x55
+
+typedef struct Gpm_Cinfo {
+ Gpm_Connect data;
+ int fd;
+ struct Gpm_Cinfo *next;
+} Gpm_Cinfo;
+
+
+/*....................................... Global variables */
+
+/* this structure is used to hide the dual-mouse stuff */
+
+struct mouse_features {
+ char *opt_type, *opt_dev, *opt_sequence;
+ int opt_baud,opt_sample,opt_delta, opt_accel, opt_scale, opt_scaley;
+ int opt_time, opt_cluster, opt_three, opt_glidepoint_tap;
+ char *opt_options; /* extra textual configuration */
+ Gpm_Type *m_type;
+ int fd;
+};
+
+extern struct mouse_features mouse_table[3], *which_mouse; /*the current one*/
+
+typedef struct Opt_struct_type {int a,B,d,i,p,r,V,A;} Opt_struct_type;
+
+/* this is not very clean, actually, but it works fine */
+#define opt_type (which_mouse->opt_type)
+#define opt_dev (which_mouse->opt_dev)
+#define opt_sequence (which_mouse->opt_sequence)
+#define opt_baud (which_mouse->opt_baud)
+#define opt_sample (which_mouse->opt_sample)
+#define opt_delta (which_mouse->opt_delta)
+#define opt_accel (which_mouse->opt_accel)
+#define opt_scale (which_mouse->opt_scale)
+#define opt_scaley (which_mouse->opt_scaley)
+#define opt_time (which_mouse->opt_time)
+#define opt_cluster (which_mouse->opt_cluster)
+#define opt_three (which_mouse->opt_three)
+#define opt_glidepoint_tap (which_mouse->opt_glidepoint_tap)
+#define opt_options (which_mouse->opt_options)
+
+#define m_type (which_mouse->m_type)
+
+/* the other variables */
+
+extern char *prgname;
+extern char *opt_lut;
+extern int opt_test, opt_ptrdrag;
+extern int opt_kill;
+extern int opt_repeater, opt_double;
+extern char* opt_repeater_type;
+extern int opt_kernel, opt_explicittype;
+extern int opt_aged;
+extern time_t opt_age_limit;
+extern char *opt_special;
+extern int opt_rawrep;
+extern int fifofd;
+extern char *consolename; /* the selected one */
+
+extern Gpm_Type *repeated_type;
+extern Gpm_Type mice[];
+extern struct winsize win;
+extern int maxx, maxy;
+extern Gpm_Cinfo *cinfo[MAX_VC+1];
+
+/*....................................... Prototypes */
+ /* gpm.c */
+int main(int argc, char **argv);
+
+ /* gpn.c */
+#define oops(s) gpm_oops(__FILE__, __LINE__,(s))
+int cmdline(int argc, char **argv);
+int giveInfo(int request, int fd);
+ /* mice.c */
+extern int M_listTypes(void);
+ /* special.c */
+int processSpecial(Gpm_Event *event);
+int twiddler_key(unsigned long message);
+int twiddler_key_init(void);
+
+/*....................................... Dirty hacks */
+
+#undef GPM_USE_MAGIC /* magic token foreach message? */
+
+
+#ifdef GPM_USE_MAGIC
+#define MAGIC_P(code) code
+#else
+#define MAGIC_P(code)
+#endif
+
+#endif /* _GPMINT_INCLUDED */
diff --git a/sys-libs/gpm/gpm-1.19.3.ebuild b/sys-libs/gpm/gpm-1.19.3.ebuild
index 8c2493b921e1..c66fd4ee6007 100644
--- a/sys-libs/gpm/gpm-1.19.3.ebuild
+++ b/sys-libs/gpm/gpm-1.19.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3.ebuild,v 1.3 2000/11/07 11:16:08 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3.ebuild,v 1.4 2000/11/12 21:35:07 achim Exp $
P=gpm-1.19.3
A=${P}.tar.gz
@@ -14,6 +14,12 @@ DEPEND=">=sys-libs/glibc-2.1.3
RDEPEND=$DEPEND
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/gpmInt.h .
+}
+
src_compile() {
cd ${S}
try ./configure --prefix=/usr
diff --git a/sys-libs/ncurses/ncurses-5.1-r1.ebuild b/sys-libs/ncurses/ncurses-5.1-r1.ebuild
index 8fa9960f17e0..3492e5a4f174 100644
--- a/sys-libs/ncurses/ncurses-5.1-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-5.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.1-r1.ebuild,v 1.7 2000/11/10 16:00:11 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.1-r1.ebuild,v 1.8 2000/11/12 21:35:07 achim Exp $
P=ncurses-5.1
A=${P}.tar.gz
@@ -11,9 +11,10 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/ncurses/${A}
ftp://ftp.gnu.org/pub/gnu/ncurses/${A}"
HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
-src_compile() {
- echo $CC $AS $LD
- try ./configure --prefix=/usr --enable-symlinks --disable-termcap --with-rpath \
+src_compile() {
+ #export CFLAGS="-V 2.95.2 ${CFLAGS}"
+ #export CXXFLAGS=$CFLAGS
+ try ./configure --prefix=/usr --enable-symlinks --disable-termcap \
--with-gpm --with-shared --without-debug --with-rcs-ids --host=${CHOST}
try make
}