summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-25 08:19:10 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-25 08:19:10 +0000
commit8e1408c05d28a52bc838e7d01bf000e7528e0d97 (patch)
tree27ae5dcb2993952ba65b7fce6c8d83209b9bf599 /sys-libs
parentRemove glibc-2.2.5-r8 mask (diff)
downloadhistorical-8e1408c05d28a52bc838e7d01bf000e7528e0d97.tar.gz
historical-8e1408c05d28a52bc838e7d01bf000e7528e0d97.tar.bz2
historical-8e1408c05d28a52bc838e7d01bf000e7528e0d97.zip
Security update
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r8.ebuild11
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r4.ebuild11
2 files changed, 13 insertions, 9 deletions
diff --git a/sys-libs/glibc/glibc-2.2.5-r8.ebuild b/sys-libs/glibc/glibc-2.2.5-r8.ebuild
index 583670d24581..9224468fd709 100644
--- a/sys-libs/glibc/glibc-2.2.5-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r8.ebuild,v 1.5 2003/03/21 09:58:56 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r8.ebuild,v 1.6 2003/03/25 08:19:10 aliz Exp $
IUSE="nls pic build"
@@ -36,8 +36,7 @@ SRC_URI="ftp://sources.redhat.com/pub/glibc/releases/glibc-${PV}.tar.bz2
ftp://sources.redhat.com/pub/glibc/releases/glibc-linuxthreads-${PV}.tar.bz2"
HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
-#KEYWORDS="x86 ppc sparc alpha arm"
-KEYWORDS="-*"
+KEYWORDS="x86 ppc sparc alpha arm"
SLOT="2.2"
LICENSE="GPL-2"
@@ -60,7 +59,11 @@ src_unpack() {
unpack glibc-${PV}.tar.bz2 || die
cd ${S}
- patch -p1 < ${FILESDIR}/glibc-xdr_security.patch
+ # Security
+ # Fix for http://www.cert.org/advisories/CA-2003-10.html
+ einfo "Applying glibc-xdr_security.patch"
+ patch -p1 < ${FILESDIR}/glibc-xdr_security.patch > /dev/null || die
+
#extract pre-made man pages. Otherwise we need perl, which is a no-no.
mkdir man; cd man
tar xjf ${FILESDIR}/glibc-manpages-${PV}.tar.bz2 > /dev/null || die
diff --git a/sys-libs/glibc/glibc-2.3.1-r4.ebuild b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
index 06ceaaad5303..e279bba6c233 100644
--- a/sys-libs/glibc/glibc-2.3.1-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.1 2003/03/21 09:58:56 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.2 2003/03/25 08:19:10 aliz Exp $
IUSE="nls pic build"
@@ -44,8 +44,7 @@ SRC_URI="http://ftp.gnu.org/gnu/glibc/glibc-${PV}.tar.gz
http://ftp.gnu.org/gnu/glibc/glibc-linuxthreads-${PV}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
-#KEYWORDS="~x86 ~ppc sparc ~alpha ~mips ~hppa"
-KEYWORDS="-*"
+KEYWORDS="x86 ppc sparc alpha mips hppa"
# Is 99% compadible, just some .a's bork
SLOT="2.2"
LICENSE="GPL-2"
@@ -81,6 +80,10 @@ src_unpack() {
cd ${S}
unpack glibc-linuxthreads-${PV}.tar.gz || die
+ # Security
+ # Fix for http://www.cert.org/advisories/CA-2003-10.html
+ epatch ${FILESDIR}/${PN}-xdr_security.patch
+
# This next patch fixes a test that will timeout due to ReiserFS' slow handling of sparse files
cd ${S}/io; epatch ${FILESDIR}/glibc-2.2.2-test-lfs-timeout.patch
@@ -159,8 +162,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/glibc23-hppa-shmlba.dpatch
fi
- epatch ${FILESDIR}/${PN}-xdr_security.patch
-
}
src_compile() {