summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-11-13 23:45:30 +0000
committerHanno Boeck <hanno@gentoo.org>2008-11-13 23:45:30 +0000
commit961bd9c0d0af310d6c717a894e913893cbbd8e81 (patch)
treec1963c85b4df2a73bf1e8d5febc7b2c0f590c114 /sys-libs
parentlibchipcard bump (diff)
downloadhistorical-961bd9c0d0af310d6c717a894e913893cbbd8e81.tar.gz
historical-961bd9c0d0af310d6c717a894e913893cbbd8e81.tar.bz2
historical-961bd9c0d0af310d6c717a894e913893cbbd8e81.zip
gwenhywfar bump
Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.28-rc4-git2 x86_64
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-3.5.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 916fe69af75a..733b37e47496 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.61 2008/11/12 09:10:06 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.62 2008/11/13 23:45:30 hanno Exp $
+
+*gwenhywfar-3.5.2 (13 Nov 2008)
+
+ 13 Nov 2008; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-3.5.2.ebuild:
+ Version bump.
12 Nov 2008; Guy Martin <gmsoft@gentoo.org> gwenhywfar-2.6.2.ebuild:
hppa stable.
diff --git a/sys-libs/gwenhywfar/gwenhywfar-3.5.2.ebuild b/sys-libs/gwenhywfar/gwenhywfar-3.5.2.ebuild
new file mode 100644
index 000000000000..753e74eebc41
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-3.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-3.5.2.ebuild,v 1.1 2008/11/13 23:45:30 hanno Exp $
+
+inherit flag-o-matic
+
+append-ldflags -Wl,--no-as-needed
+RESTRICT="test"
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="http://files.hboeck.de/aq/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+RDEPEND="ssl? ( net-libs/gnutls )
+ sys-libs/ncurses
+ ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ $(use_enable ncurses gwenui) \
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
+ fi
+ find "${D}" -name '*.la' -delete
+}