summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-14 06:43:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-14 06:43:26 +0000
commit9b0f3c99e4f6d65933ede012502d7ca71c8e9435 (patch)
treef52f3c354d024688e4520428ccf5a12d5ced591e /sys-libs
parentfixing the digest (diff)
downloadhistorical-9b0f3c99e4f6d65933ede012502d7ca71c8e9435.tar.gz
historical-9b0f3c99e4f6d65933ede012502d7ca71c8e9435.tar.bz2
historical-9b0f3c99e4f6d65933ede012502d7ca71c8e9435.zip
make sure we install the sys-include symlink for gcc
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc/Manifest8
-rw-r--r--sys-libs/uclibc/uclibc-0.9.26-r8.ebuild10
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/uclibc/Manifest b/sys-libs/uclibc/Manifest
index f80ec8a03f34..a1d0cda2b8a1 100644
--- a/sys-libs/uclibc/Manifest
+++ b/sys-libs/uclibc/Manifest
@@ -4,7 +4,7 @@ Hash: SHA1
MD5 a6d5bf199998859971d78244fd572b29 ChangeLog 8164
MD5 e96b4dfc373a1cdf7735aeae52c4cf7e metadata.xml 999
MD5 a4612f199b26df52b09c0055f5672567 uclibc-0.9.26-r7.ebuild 7862
-MD5 7927a275866d47aec82774fa32ae46ed uclibc-0.9.26-r8.ebuild 9547
+MD5 d942a37aaa0f2fb3c52228a50fe26dbb uclibc-0.9.26-r8.ebuild 9772
MD5 6fb9166cb9a919ce76e4ebd58f74fec5 files/0.9.26-r8-cvs.patch 1184
MD5 0b733285f186f31c1be9ffcc42f1064e files/getent 973
MD5 e0556dd58957468793213ab327c590d3 files/digest-uclibc-0.9.26-r8 232
@@ -20,7 +20,7 @@ MD5 a503ef49001f5f67d61cd40b0809fb76 files/0.9.26/unsecvars.h 682
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB50mRroRuSHgZdywRAkUgAJ4j2EUWJtH2NeC5k6eevSQDZe4qpACfZ5d7
-y3a6BEKI+IODipQhG7Cvr3M=
-=qU91
+iD8DBQFB52rdroRuSHgZdywRApBhAJ9d5KSpbsDauqKCFWN7edcHwXvAFwCeIff1
+a3Hb0LPo1oOYYoM3/ExaGTo=
+=dOUj
-----END PGP SIGNATURE-----
diff --git a/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild b/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
index ae4024c84399..a2fb9d793e53 100644
--- a/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild,v 1.3 2005/01/14 04:24:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild,v 1.4 2005/01/14 06:43:26 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -265,7 +265,13 @@ src_install() {
# scsi is uclibc's own directory since cvs 20040212
rm -r "${D}"$(alt_prefix)/include/{asm,linux,asm-generic}
- [[ ${CTARGET} != ${CHOST} ]] && return 0
+ if [[ ${CTARGET} != ${CHOST} ]] ; then
+ # Need this symlink in order for gcc to find the system
+ # headers properly when creating final stage compiler.
+ # See the '--with-headers' option in the gcc manual.
+ dosym include $(alt_prefix)/sys-include
+ return 0
+ fi
if [[ ${CHOST} == *-uclibc ]] ; then
emake PREFIX="${D}" install_utils || die "install-utils failed"