summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-23 22:16:16 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-23 22:16:16 +0000
commitb1d67e6679d2fd9dc58db10d47591162d9e2ac21 (patch)
tree185e3b6b8b22e6eb36ae6e0a557b13756385724e /sys-libs
parentchanged incorrect configure option (diff)
downloadhistorical-b1d67e6679d2fd9dc58db10d47591162d9e2ac21.tar.gz
historical-b1d67e6679d2fd9dc58db10d47591162d9e2ac21.tar.bz2
historical-b1d67e6679d2fd9dc58db10d47591162d9e2ac21.zip
nptl fixes; cleanups
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/db-3.2.9-r2.ebuild125
-rw-r--r--sys-libs/db/files/db-3.2.9-fix-dep-link.patch26
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r21
4 files changed, 161 insertions, 1 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 7acd5291aa99..cf379750519d 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.20 2003/02/20 22:00:24 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.21 2003/02/23 22:16:16 azarah Exp $
+
+*db-3.2.9-r2 (23 Feb 2003)
+
+ 23 Feb 2003; Martin Schlemmer <azarah@gentoo.org> :
+ Fix build to link libdb*.so to dependency libs .. for instance when building
+ with NPTL we need to link to libpthread.
+ Fix the db185 stuff to not have to hack the build to pieces to build.
+ We should compile shared and static libs in two diff build dirs ...
20 Feb 2003; Zach Welch <zwelch@gentoo.org> db-1.85-r1.ebuild , db-3.2.9-r1.ebuild :
Added arm to keywords.
diff --git a/sys-libs/db/db-3.2.9-r2.ebuild b/sys-libs/db/db-3.2.9-r2.ebuild
new file mode 100644
index 000000000000..efca48e79696
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r2.ebuild,v 1.1 2003/02/23 22:16:16 azarah Exp $
+
+IUSE=""
+
+inherit libtool
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 to else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ cp ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+}
+
+src_compile() {
+ local conf=
+
+ conf="--host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+ # --enable-rpc aparently does not work .. should verify this
+ # at some stage ...
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} \
+ --enable-shared || die
+
+ # Parallel make does not work
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ make || die
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ make || die
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${S}/build-static
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/docs
+}
+
diff --git a/sys-libs/db/files/db-3.2.9-fix-dep-link.patch b/sys-libs/db/files/db-3.2.9-fix-dep-link.patch
new file mode 100644
index 000000000000..cdf6599b0d55
--- /dev/null
+++ b/sys-libs/db/files/db-3.2.9-fix-dep-link.patch
@@ -0,0 +1,26 @@
+--- db-3.2.9/dist/Makefile.in.orig 2003-02-23 23:41:13.000000000 +0200
++++ db-3.2.9/dist/Makefile.in 2003-02-23 23:42:07.000000000 +0200
+@@ -240,19 +240,19 @@
+
+ $(libso_target): $(OBJS)
+ $(SOLINK) $(SOFLAGS) -o $(libso_target) \
+- $(OBJS) $(LDFLAGS) $(LIBSO_LIBS)
++ $(OBJS) $(LDFLAGS) $(LIBS) $(LIBSO_LIBS)
+
+ $(libxso_target): $(COBJS) $(OBJS)
+ $(SOLINK) $(SOFLAGS) -o $(libxso_target) \
+- $(COBJS) $(OBJS) $(LDFLAGS) $(LIBXSO_LIBS)
++ $(COBJS) $(OBJS) $(LDFLAGS) $(LIBS) $(LIBXSO_LIBS)
+
+ $(libjso_target): $(JOBJS) $(OBJS)
+ $(SOLINK) $(SOFLAGS) -o $(libjso_target) \
+- $(JOBJS) $(OBJS) $(LDFLAGS) $(LIBJSO_LIBS)
++ $(JOBJS) $(OBJS) $(LDFLAGS) $(LIBS) $(LIBJSO_LIBS)
+
+ $(libtso_target): $(TOBJS) $(OBJS)
+ $(SOLINK) $(SOFLAGS) -o $(libtso_target) \
+- $(TOBJS) $(OBJS) $(LDFLAGS) $(LIBTSO_LIBS)
++ $(TOBJS) $(OBJS) $(LDFLAGS) $(LIBS) $(LIBTSO_LIBS)
+
+ ##################################################
+ # Creating individual dependencies and actions for building class
diff --git a/sys-libs/db/files/digest-db-3.2.9-r2 b/sys-libs/db/files/digest-db-3.2.9-r2
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r2
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238