summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-11 04:00:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-11 04:00:05 +0000
commitb7dca189b693f542ab5e002f2908ed48e1244b17 (patch)
tree9b83803d2ae5bcd10b9e04edf3dfc5383c2fa825 /sys-libs
parentmodified patch from mrbones. closes #83794. (diff)
downloadhistorical-b7dca189b693f542ab5e002f2908ed48e1244b17.tar.gz
historical-b7dca189b693f542ab5e002f2908ed48e1244b17.tar.bz2
historical-b7dca189b693f542ab5e002f2908ed48e1244b17.zip
old
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/Manifest2
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.4-r11
-rw-r--r--sys-libs/ncurses/ncurses-5.4-r1.ebuild159
3 files changed, 0 insertions, 162 deletions
diff --git a/sys-libs/ncurses/Manifest b/sys-libs/ncurses/Manifest
index 2dc82ca165e4..3284eca6c90f 100644
--- a/sys-libs/ncurses/Manifest
+++ b/sys-libs/ncurses/Manifest
@@ -1,11 +1,9 @@
MD5 d31c07996e130722a3e37b6747424bbe ChangeLog 14200
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 247464abc4ec5b7449d43f45a268eea5 ncurses-5.4-r1.ebuild 4783
MD5 827c26440352d71054e791be9a20af85 ncurses-5.4-r5.ebuild 5743
MD5 1d92671261d5e5ddcb50f26da871bdf8 ncurses-8.1.ebuild 406
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-ncurses-8.1 0
MD5 2167b54d7c96964183554e767e5f5376 files/xterm-debian.ti 342
MD5 1ecbf68a55269d2cebeb997f6973fc1d files/ncurses-5.4-share-sed.patch 686
MD5 61ecd5aac5ddbd35cc4d4a00282eed01 files/ncurses-5.4-xterm.patch 495
-MD5 a370aabb0870d2822a0ab839947919f3 files/digest-ncurses-5.4-r1 64
MD5 a370aabb0870d2822a0ab839947919f3 files/digest-ncurses-5.4-r5 64
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.4-r1 b/sys-libs/ncurses/files/digest-ncurses-5.4-r1
deleted file mode 100644
index fdf84beb38f9..000000000000
--- a/sys-libs/ncurses/files/digest-ncurses-5.4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 069c8880072060373290a4fefff43520 ncurses-5.4.tar.gz 2154022
diff --git a/sys-libs/ncurses/ncurses-5.4-r1.ebuild b/sys-libs/ncurses/ncurses-5.4-r1.ebuild
deleted file mode 100644
index 581424a957ca..000000000000
--- a/sys-libs/ncurses/ncurses-5.4-r1.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.4-r1.ebuild,v 1.28 2005/01/03 00:24:18 ciaranm Exp $
-
-inherit eutils flag-o-matic 64-bit gnuconfig
-
-DESCRIPTION="console display library"
-HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
-SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="5"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="debug"
-
-DEPEND="virtual/libc"
-# This doesn't fix the problem. bootstrap builds ncurses again with
-# normal USE flags while bootstrap is unset, which apparently causes
-# things to break -- avenj 2 Apr 04
-# !bootstrap? ( gpm? ( sys-libs/gpm ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-xterm.patch
- # Bug #42336.
- epatch ${FILESDIR}/${P}-share-sed.patch
- gnuconfig_update
-}
-
-src_compile() {
- local myconf=
-
- filter-flags -fno-exceptions
-
- use debug || myconf="${myconf} --without-debug"
-
- # Shared objects are compiled properly with -fPIC, but
- # standard libs also require this.
- 64-bit && append-flags -fPIC
- filter-ldflags -pie
-
- # From version 5.3, ncurses also build c++ bindings, and as
- # we do not have a c++ compiler during bootstrap, disable
- # building it. We will rebuild ncurses after gcc's second
- # build in bootstrap.sh.
- # <azarah@gentoo.org> (23 Oct 2002)
- ( use build || use bootstrap ) \
- && myconf="${myconf} --without-cxx --without-cxx-binding --without-ada"
-
- # see note about DEPEND above -- avenj@gentoo.org 2 Apr 04
-# use gpm && myconf="${myconf} --with-gpm"
-
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
- econf \
- --libdir=/$(get_libdir) \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --disable-termcap \
- --with-shared \
- --with-rcs-ids \
- --without-ada \
- --enable-symlinks \
- ${myconf} \
- || die "configure failed"
-
- # A little hack to fix parallel builds ... they break when
- # generating sources so if we generate the sources first (in
- # non-parallel), we can then build the rest of the package
- # in parallel. This is not really a perf hit since the source
- # generation is quite small. -vapier
- emake -j1 sources || die "make sources failed"
- emake || die "make failed"
-}
-
-src_install() {
- local x=
-
- make DESTDIR=${D} install || die "make install failed"
-
- # Move static and extraneous ncurses libraries out of /lib
- cd ${D}/$(get_libdir)
- dodir /usr/$(get_libdir)
- mv libform* libmenu* libpanel* ${D}/usr/$(get_libdir)
- mv *.a ${D}/usr/$(get_libdir)
- # bug #4411
- gen_usr_ldscript libncurses.so || die "gen_usr_ldscript failed"
- gen_usr_ldscript libcurses.so || die "gen_usr_ldscript failed"
-
- # We need the basic terminfo files in /etc, bug #37026
- einfo "Installing basic terminfo files in /etc..."
- for x in dumb linux rxvt screen sun vt{52,100,102,220} xterm
- do
- local termfile="$(find "${D}/usr/share/terminfo/" -name "${x}" 2>/dev/null)"
- local basedir="$(basename $(dirname "${termfile}"))"
-
- if [ -n "${termfile}" ]
- then
- dodir /etc/terminfo/${basedir}
- mv ${termfile} ${D}/etc/terminfo/${basedir}/
- dosym ../../../../etc/terminfo/${basedir}/${x} \
- /usr/share/terminfo/${basedir}/${x}
- fi
- done
-
- # Build fails to create this ...
- dosym ../share/terminfo /usr/$(get_libdir)/terminfo
-
- dodir /etc/env.d
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > ${D}/etc/env.d/50ncurses
-
- if use build
- then
- cd ${D}
- rm -rf usr/share/man
- cd usr/share/terminfo
- cp -a l/linux n/nxterm v/vt100 ${T}
- rm -rf *
- mkdir l x v
- cp -a ${T}/linux l
- cp -a ${T}/nxterm x/xterm
- cp -a ${T}/vt100 v
- # bash compilation requires static libncurses libraries, so
- # this breaks the "build a new build image" system. We now
- # need to remove libncurses.a from the build image manually.
- # cd ${D}/usr/lib; rm *.a
- else
- # Install xterm-debian terminfo entry to satisfy bug #18486
- LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${D}/usr/$(get_libdir):${D}/$(get_libdir) \
- TERMINFO=${D}/usr/share/terminfo \
- ${D}/usr/bin/tic ${FILESDIR}/xterm-debian.ti
-
- cd ${S}
- dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
- dodoc doc/*.doc
- dohtml -r doc/html/
- fi
-}
-
-pkg_preinst() {
- if [ ! -f "${ROOT}/etc/env.d/50ncurses" ]
- then
- mkdir -p "${ROOT}/etc/env.d"
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > \
- ${ROOT}/etc/env.d/50ncurses
- fi
-}
-
-pkg_postinst() {
- # Old ncurses may still be around from old build tbz2's.
- rm -f ${ROOT}/lib/libncurses.so.5.[23]
- rm -f ${ROOT}/usr/lib/lib{form,menu,panel}.so.5.[23]
- if [ "$(get_libdir)" != "lib" ] ;then
- rm -f ${ROOT}/$(get_libdir)/libncurses.so.5.[23]
- rm -f ${ROOT}/usr/$(get_libdir)/lib{form,menu,panel}.so.5.[23]
- fi
-}