summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-18 08:45:18 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-18 08:45:18 +0000
commit31155468b82852c0c44f0eeddebe7c66bef7389e (patch)
tree4c373d0f4c01ebc1d99de0a0c361298ac63afc62 /sys-power/phc-k8/phc-k8-0.4.3.ebuild
parentFixed init script for multislotting. Bug 390307. Thanks to Guillaume Castagni... (diff)
downloadhistorical-31155468b82852c0c44f0eeddebe7c66bef7389e.tar.gz
historical-31155468b82852c0c44f0eeddebe7c66bef7389e.tar.bz2
historical-31155468b82852c0c44f0eeddebe7c66bef7389e.zip
Version bump. Add linux 3 warning (bug 376441).
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'sys-power/phc-k8/phc-k8-0.4.3.ebuild')
-rw-r--r--sys-power/phc-k8/phc-k8-0.4.3.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/sys-power/phc-k8/phc-k8-0.4.3.ebuild b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
index 5c1eff8647ae..d505be41d104 100644
--- a/sys-power/phc-k8/phc-k8-0.4.3.ebuild
+++ b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.3.ebuild,v 1.1 2010/12/04 19:34:35 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.3.ebuild,v 1.2 2011/11/18 08:45:18 xmw Exp $
-EAPI=2
+EAPI=4
inherit linux-info linux-mod
@@ -17,14 +17,25 @@ IUSE=""
S=${WORKDIR}/${PN}_v${PV}
-CONFIG_CHECK="~!X86_POWERNOW_K8"
-ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
+pkg_pretend() {
+ if kernel_is gt 3 0 0 ; then
+ eerror "This version is not compartible with linux 3.x (bug 376441)"
+ eerror "Please use >=sys-power/phc-k8-0.4.4 !"
+ einfo ; einfo ; einfo
+ die "wrong kernel version"
+ fi
+}
+
+pkg_setup() {
+ CONFIG_CHECK="~!X86_POWERNOW_K8"
+ ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
a) include needed symbol cpufreq_get_measured_perf and
b) enable the replacemant of powernow-k8 with phc-k8."
-MODULE_NAMES="phc-k8(misc:)"
-BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
-BUILD_TARGETS="all"
+ MODULE_NAMES="phc-k8(misc:)"
+ BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+ BUILD_TARGETS="all"
+}
src_install() {
linux-mod_src_install