summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-05 21:42:46 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-05 21:42:46 +0000
commitb3e68e4caa333d70527464ad41004c9888bd62c7 (patch)
tree714c81760f07eef036324ddac4a111f6b7aed404 /sys-power/suspend/suspend-1.0.ebuild
parentVersion bump. (diff)
downloadhistorical-b3e68e4caa333d70527464ad41004c9888bd62c7.tar.gz
historical-b3e68e4caa333d70527464ad41004c9888bd62c7.tar.bz2
historical-b3e68e4caa333d70527464ad41004c9888bd62c7.zip
Version bump
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'sys-power/suspend/suspend-1.0.ebuild')
-rw-r--r--sys-power/suspend/suspend-1.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/suspend/suspend-1.0.ebuild b/sys-power/suspend/suspend-1.0.ebuild
new file mode 100644
index 000000000000..0feabba23ab3
--- /dev/null
+++ b/sys-power/suspend/suspend-1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-1.0.ebuild,v 1.1 2011/05/05 21:42:46 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/-utils-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fbsplash crypt threads"
+
+X86_RDEPEND="dev-libs/libx86"
+X86_DEPEND="
+ ${X86_RDEPEND}
+ >=sys-apps/pciutils-2.2.4"
+RDEPEND=">=dev-libs/lzo-2[static-libs]
+ fbsplash? ( >=media-gfx/splashutils-1.5.2 )
+ crypt? ( dev-libs/libgcrypt[static-libs]
+ dev-libs/libgpg-error[static-libs] )
+ x86? ( ${X86_RDEPEND} )
+ amd64? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ x86? ( ${X86_DEPEND} )
+ amd64? ( ${X86_DEPEND} )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P/-/-utils-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9_pre0-errno.patch
+ sed -i -e "/AC_INIT/s/0\.8/0.9-${MY_GIT_SHORT_COMMIT}/" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-compress \
+ $(use_enable crypt encrypt) \
+ $(use_enable fbsplash) \
+ $(use_enable threads) \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=156445"
+}