summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-01-22 19:20:18 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-01-22 19:20:18 +0000
commit025ab4a4c1ea4be3787e7104d127ecd278ad4bfa (patch)
treeb6629c38dda5daa1cc96269fe807b0058f4d8d9e /www-apache/mod_backhand/mod_backhand-1.2.2.ebuild
parentAdd bash-completion script. For now this is vim-7 only. If it seems to work w... (diff)
downloadhistorical-025ab4a4c1ea4be3787e7104d127ecd278ad4bfa.tar.gz
historical-025ab4a4c1ea4be3787e7104d127ecd278ad4bfa.tar.bz2
historical-025ab4a4c1ea4be3787e7104d127ecd278ad4bfa.zip
initial revision of mod_backhand
Diffstat (limited to 'www-apache/mod_backhand/mod_backhand-1.2.2.ebuild')
-rw-r--r--www-apache/mod_backhand/mod_backhand-1.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_backhand/mod_backhand-1.2.2.ebuild b/www-apache/mod_backhand/mod_backhand-1.2.2.ebuild
new file mode 100644
index 000000000000..bafc50d0cc1b
--- /dev/null
+++ b/www-apache/mod_backhand/mod_backhand-1.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_backhand/mod_backhand-1.2.2.ebuild,v 1.1 2005/01/22 19:20:18 hollow Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Apache module for load balancing and web clustering"
+HOMEPAGE="http://www.backhand.org/mod_backhand/"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.gz"
+
+KEYWORDS="~x86"
+DEPEND=""
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+DOCFILES="ChangeLog INSTALL LICENSE NOTES NOTICE README.bySession TODO"
+
+APACHE1_MOD_CONF="05_${PN}"
+APACHE1_MOD_DEFINE="BACKHAND"
+
+APXS1_ARGS="-c -o ${PN}.so apue.c arriba.c back_util.c builtins.c ${PN}.c"
+
+need_apache1
+
+src_compile() {
+ econf
+ apache-module_src_compile
+ ${APXS1} -c -o byHostname.so byHostname.c || die "apxs failed"
+}
+
+src_install() {
+ apache-module_src_install
+}
+
+pkg_postinst() {
+ install -d -m 0755 -o apache -g apache ${ROOT}/var/lib/backhand
+ apache-module_pkg_postinst
+}