summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-10 15:47:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-10 15:47:30 +0000
commit88e47f383b708a3bd98656a4c20a9e15dd797d26 (patch)
tree8f91e5ca9de950aa664f404b2c525cd5067685c6 /www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
parentAdded pkg_postinst. bug #176533. (diff)
downloadhistorical-88e47f383b708a3bd98656a4c20a9e15dd797d26.tar.gz
historical-88e47f383b708a3bd98656a4c20a9e15dd797d26.tar.bz2
historical-88e47f383b708a3bd98656a4c20a9e15dd797d26.zip
fix #205169
Package-Manager: portage-2.1.4_rc11
Diffstat (limited to 'www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild')
-rw-r--r--www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
index 9143f047be2d..04443aab9c5d 100644
--- a/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
+++ b/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild,v 1.1 2007/09/08 17:04:32 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_whatkilledus/mod_whatkilledus-0.0.1.ebuild,v 1.2 2008/01/10 15:47:30 hollow Exp $
inherit apache-module eutils toolchain-funcs
@@ -19,7 +19,14 @@ RDEPEND=""
APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="WHATKILLEDUS"
-need_apache2
+need_apache2_2
+
+pkg_setup() {
+ apache-module_pkg_setup
+ if ! built_with_use www-servers/apache debug; then
+ die "you need to build www-servers/apache with USE=debug"
+ fi
+}
src_unpack() {
mkdir -p "${S}" || die "mkdir S failed"
@@ -28,8 +35,8 @@ src_unpack() {
src_compile() {
$(tc-getCC) \
- $($(apr_config) --includes) \
- $($(apr_config) --cppflags) \
+ $(/usr/bin/apr-1-config --includes) \
+ $(/usr/bin/apr-1-config --cppflags) \
-o "${S}"/gen_test_char \
"${FILESDIR}"/gen_test_char.c
"${S}"/gen_test_char > "${S}"/test_char.h