summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 17:50:04 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 17:50:04 +0000
commita2bc5e2821ee23ccf1c4f84d5a90a785261da288 (patch)
tree7797def2a28abc89cb28ad8119fed0e5bd4cc4cc /www-apps/389-dsgw/389-dsgw-1.1.10.ebuild
parentVersion bump. (diff)
downloadhistorical-a2bc5e2821ee23ccf1c4f84d5a90a785261da288.tar.gz
historical-a2bc5e2821ee23ccf1c4f84d5a90a785261da288.tar.bz2
historical-a2bc5e2821ee23ccf1c4f84d5a90a785261da288.zip
version bump, fixes #461522
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 Manifest-Sign-Key: 0xADC916E5
Diffstat (limited to 'www-apps/389-dsgw/389-dsgw-1.1.10.ebuild')
-rw-r--r--www-apps/389-dsgw/389-dsgw-1.1.10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/389-dsgw/389-dsgw-1.1.10.ebuild b/www-apps/389-dsgw/389-dsgw-1.1.10.ebuild
new file mode 100644
index 000000000000..d113a4f14214
--- /dev/null
+++ b/www-apps/389-dsgw/389-dsgw-1.1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/389-dsgw/389-dsgw-1.1.10.ebuild,v 1.1 2013/03/14 17:50:00 lxnay Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="389 Directory Server Gateway Web Application"
+HOMEPAGE="http://port389.org/"
+SRC_URI="http://directory.fedoraproject.org/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +adminserver"
+
+DEPEND="adminserver? ( net-nds/389-admin )
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/cyrus-sasl
+ dev-libs/icu
+ dev-libs/389-adminutil
+ net-nds/openldap"
+
+RDEPEND="${DEPEND}
+ dev-perl/perl-mozldap
+ virtual/perl-CGI"
+
+src_prepare() {
+ # as per 389 documentation, when 64bit, export USE_64
+ use amd64 && export USE_64=1
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with adminserver) \
+ --with-adminutil=/usr \
+ --with-fhs \
+ --with-openldap || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+}