summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-17 23:28:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-17 23:28:43 +0000
commitfa9e33e13fcb464e21fc5c60fb1aa602ed3a2eee (patch)
treeef053b3a61c953d815f3aeabe0a9622446369d34 /www-apps/b2evolution/b2evolution-1.10.2.ebuild
parentfix python eclass use, bug #207667 (diff)
downloadhistorical-fa9e33e13fcb464e21fc5c60fb1aa602ed3a2eee.tar.gz
historical-fa9e33e13fcb464e21fc5c60fb1aa602ed3a2eee.tar.bz2
historical-fa9e33e13fcb464e21fc5c60fb1aa602ed3a2eee.zip
ebuild cleanup wrt #208584
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'www-apps/b2evolution/b2evolution-1.10.2.ebuild')
-rw-r--r--www-apps/b2evolution/b2evolution-1.10.2.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/www-apps/b2evolution/b2evolution-1.10.2.ebuild b/www-apps/b2evolution/b2evolution-1.10.2.ebuild
index 17e9bccf67d7..094a64e52608 100644
--- a/www-apps/b2evolution/b2evolution-1.10.2.ebuild
+++ b/www-apps/b2evolution/b2evolution-1.10.2.ebuild
@@ -1,58 +1,52 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/b2evolution-1.10.2.ebuild,v 1.5 2007/08/14 18:15:31 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/b2evolution-1.10.2.ebuild,v 1.6 2008/02/17 23:28:43 hollow Exp $
inherit webapp eutils depend.php
-MY_EXT="-2007-06-08"
+MY_EXT="2007-06-08"
+MY_PV=${PV/_/-}
DESCRIPTION="Multilingual multiuser multi-blog engine"
HOMEPAGE="http://www.b2evolution.net"
-SRC_URI="mirror://sourceforge/evocms/${P}${MY_EXT}.zip"
+SRC_URI="mirror://sourceforge/evocms/${PN}-${MY_PV}-${MY_EXT}.zip"
+
LICENSE="GPL-2"
KEYWORDS="alpha amd64 ppc x86"
IUSE=""
-RDEPEND="virtual/httpd-php"
+RDEPEND=""
DEPEND="${DEPEND} ${RDEPEND}
app-arch/unzip"
+need_php_httpd
+
S="${WORKDIR}/${PN}"
pkg_setup() {
webapp_pkg_setup
has_php
if [[ ${PHP_VERSION} == "4" ]]; then
- require_php_with_use expat
+ require_php_with_use expat tokenizer mysql
else
- require_php_with_use xml
+ require_php_with_use xml tokenizer mysql
fi
}
-pkg_setup() {
- webapp_pkg_setup
- require_php_with_use tokenizer mysql
-}
-
src_install() {
webapp_src_preinst
- einfo "Installing main files"
- cp -r blogs/* ${D}${MY_HTDOCSDIR}
- einfo "Done"
+ insinto ${MY_HTDOCSDIR}
+ doins -r blogs/*
- dodoc doc/license.txt doc/install_new.html doc/upgradefrom_b2evo.html doc/upgradefrom_b2.html \
- doc/upgradefrom_mt.html
+ rm doc/*.*-*.html doc/*.src.html
+ dohtml doc/*.html
- # Identify the configuration files that this app uses
- # User can want to make changes to these!
webapp_serverowned ${MY_HTDOCSDIR}
webapp_serverowned ${MY_HTDOCSDIR}/conf/_basic_config.php
webapp_configfile ${MY_HTDOCSDIR}/conf/_{basic_config,advanced,locales,formatting,admin,stats,application}.php
- # post-install instructions
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- # now strut stuff
webapp_src_install
}