summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-06-15 18:41:52 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-06-15 18:41:52 +0000
commit4eb80f98da8cf31c83d8c1cd452896cc77e45dc6 (patch)
tree11db9fa8e5caff83dcbaeff3a8dec7e7e7ca6ab3 /www-apps/horde/horde-3.1.1-r1.ebuild
parentppc stable, bug #136720 (diff)
downloadhistorical-4eb80f98da8cf31c83d8c1cd452896cc77e45dc6.tar.gz
historical-4eb80f98da8cf31c83d8c1cd452896cc77e45dc6.tar.bz2
historical-4eb80f98da8cf31c83d8c1cd452896cc77e45dc6.zip
Fix bug #136830.
Package-Manager: portage-2.1
Diffstat (limited to 'www-apps/horde/horde-3.1.1-r1.ebuild')
-rw-r--r--www-apps/horde/horde-3.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/horde/horde-3.1.1-r1.ebuild b/www-apps/horde/horde-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..d7d0e71a9714
--- /dev/null
+++ b/www-apps/horde/horde-3.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-3.1.1-r1.ebuild,v 1.1 2006/06/15 18:41:52 chtekk Exp $
+
+HORDE_PHP_FEATURES="session xml"
+
+# Patch to fix bug #136830
+EHORDE_PATCHES="${FILESDIR}/${P}-xss.diff"
+
+inherit horde
+
+DESCRIPTION="Horde Application Framework"
+HOMEPAGE="http://www.horde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="mysql"
+
+DEPEND=""
+RDEPEND="virtual/php
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=www-apps/horde-pear-1.3
+ dev-php/PEAR-Log
+ dev-php/PEAR-Mail_Mime
+ mysql? ( dev-php/PEAR-DB )"
+
+pkg_postinst() {
+ horde_pkg_postinst
+ echo
+ einfo "Horde requires PHP to have:"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php/apache2-php4/php.ini"
+}