summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-04-25 08:24:23 +0000
committerChristian Parpart <trapni@gentoo.org>2005-04-25 08:24:23 +0000
commit825f23e537b7baa4070545ab201a8414e183e519 (patch)
tree41aeef3279c0189cd694568474f42f1c3db4460f /www-apps/mediawiki/mediawiki-1.4.1.ebuild
parentn-c-b requires USE='unicode' cdrtools, added a pkg_setup() check for 2.8.7, s... (diff)
downloadhistorical-825f23e537b7baa4070545ab201a8414e183e519.tar.gz
historical-825f23e537b7baa4070545ab201a8414e183e519.tar.bz2
historical-825f23e537b7baa4070545ab201a8414e183e519.zip
version bump
Package-Manager: portage-2.0.51.20-r4
Diffstat (limited to 'www-apps/mediawiki/mediawiki-1.4.1.ebuild')
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.1.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/www-apps/mediawiki/mediawiki-1.4.1.ebuild b/www-apps/mediawiki/mediawiki-1.4.1.ebuild
new file mode 100644
index 000000000000..6cf5ce1adf52
--- /dev/null
+++ b/www-apps/mediawiki/mediawiki-1.4.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.1.ebuild,v 1.1 2005/04/25 08:24:23 trapni Exp $
+
+inherit webapp
+
+DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
+HOMEPAGE="http://www.mediawiki.org"
+SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="imagemagick math"
+
+S="${WORKDIR}/${P/.0_/}"
+
+DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
+
+RDEPEND="virtual/php
+ >=dev-db/mysql-4
+ math? ( app-text/tetex
+ app-text/ghostscript
+ media-gfx/imagemagick )
+ imagemagick? ( media-gfx/imagemagick )"
+
+src_compile() {
+ if use math; then
+ einfo "Compiling math support"
+ cd math || die
+ emake || die
+ else
+ einfo "No math support enabled. Skipping."
+ fi
+
+ # TODO: think about includes/zhtable/ support
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # copy the app's main files excluding math support, docs, and tests
+ local DIRS="
+ config
+ extensions
+ images
+ includes
+ includes/normal
+ includes/templates
+ includes/zhtable
+ irc
+ languages
+ maintenance
+ maintenance/archives
+ maintenance/postgresql
+ skins
+ skins/amethyst
+ skins/chick
+ skins/common
+ skins/common/images
+ skins/disabled
+ skins/monobook
+ skins/myskin
+ "
+ insinto ${MY_HTDOCSDIR}
+ doins *.php *.inc *.phtml
+ for DIR in ${DIRS}; do
+ dodir ${MY_HTDOCSDIR}/${DIR}
+ insinto ${MY_HTDOCSDIR}/${DIR}
+ doins ${DIR}/*
+ test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
+ done
+
+ # installing some docs
+ local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
+ for DOC in ${DOCS}; do
+ dodoc "${DOC}"
+ rm -f "${DOC}"
+ done
+ dodoc docs/*.doc
+ rm -f docs/*.doc
+
+ docinto php-memcached
+ dodoc docs/php-memcached/*
+
+ # If imagemagick is enabled then setup for image upload.
+ # We ensure the directory is prepared for writing. The post-
+ # install instructions guide the user to enable the feature.
+ if use imagemagick; then
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ fi
+
+ # If we've enabled math USE-flag, install math support.
+ # We ensure the directories are prepared for writing. The post-
+ # install instructions guide the user to enable the feature.
+ if use math; then
+ einfo "Installing math support"
+ dodir ${MY_HTDOCSDIR}/math
+ exeinto ${MY_HTDOCSDIR}/math
+ doexe math/texvc
+
+ # Docs
+ docinto math
+ dodoc math/README math/TODO
+
+ # Working directories. Server writeable.
+ dodir ${MY_HTDOCSDIR}/images/math
+ webapp_serverowned ${MY_HTDOCSDIR}/images/math
+ dodir ${MY_HTDOCSDIR}/images/tmp
+ webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
+ fi
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
+ webapp_src_install
+}