summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2013-03-19 22:49:19 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2013-03-19 22:49:19 +0000
commit119a1bf8248145902b9787b97abf0f67d5acb93c (patch)
treeca3d0f64378ac713750973dc9a4e7c6d7c195022 /www-client/chromium/chromium-9999-r1.ebuild
parentchanged the description in the ebuild (diff)
downloadhistorical-119a1bf8248145902b9787b97abf0f67d5acb93c.tar.gz
historical-119a1bf8248145902b9787b97abf0f67d5acb93c.tar.bz2
historical-119a1bf8248145902b9787b97abf0f67d5acb93c.zip
Dev channel bump. Remove old.
Package-Manager: portage-2.1.11.52/cvs/Linux i686 Manifest-Sign-Key: 0x30427902
Diffstat (limited to 'www-client/chromium/chromium-9999-r1.ebuild')
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 4de68106d55e..7e6fbaa0f679 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.182 2013/03/13 23:27:24 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.183 2013/03/19 22:49:07 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ ESVN_REPO_URI="http://src.chromium.org/svn/trunk/src"
LICENSE="BSD"
SLOT="live"
KEYWORDS=""
-IUSE="cups gnome gnome-keyring gps kerberos pulseaudio selinux system-sqlite tcmalloc"
+IUSE="cups gnome gnome-keyring gps kerberos selinux system-sqlite tcmalloc"
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
@@ -56,9 +56,8 @@ RDEPEND="app-accessibility/speech-dispatcher:=
!arm? ( !x86? ( >=media-libs/mesa-9.1:=[gles2] ) )
media-libs/opus:=
media-libs/speex:=
- pulseaudio? ( media-sound/pulseaudio:= )
+ media-sound/pulseaudio:=
>=media-video/ffmpeg-1.0:=[opus]
- >=net-libs/libsrtp-1.4.4_p20121108:=
sys-apps/dbus:=
sys-apps/pciutils:=
sys-libs/zlib:=[minizip]
@@ -209,6 +208,7 @@ src_prepare() {
\! -path 'third_party/leveldatabase/*' \
\! -path 'third_party/libjingle/*' \
\! -path 'third_party/libphonenumber/*' \
+ \! -path 'third_party/libsrtp/*' \
\! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libXNVCtrl/*' \
\! -path 'third_party/libyuv/*' \
@@ -272,6 +272,7 @@ src_configure() {
# Use system-provided libraries.
# TODO: use_system_hunspell (upstream changes needed).
+ # TODO: use_system_libsrtp (bug #459932).
# TODO: use_system_ssl (http://crbug.com/58087).
# TODO: use_system_sqlite (http://crbug.com/22208).
myconf+="
@@ -284,7 +285,6 @@ src_configure() {
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
- -Duse_system_libsrtp=1
-Duse_system_libusb=1
-Duse_system_libvpx=1
-Duse_system_libwebp=1
@@ -325,7 +325,6 @@ src_configure() {
$(gyp_use gps linux_use_libgps)
$(gyp_use gps linux_link_libgps)
$(gyp_use kerberos)
- $(gyp_use pulseaudio)
$(gyp_use selinux selinux)"
if use system-sqlite; then