summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-02 18:40:41 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-02 18:40:41 +0000
commit1f2d470b34e8600211205178726223951d3fad46 (patch)
tree0956a0ba7b4f74b8051985afcdeaeb6a883bde27 /www-client/chromium/chromium-9999-r1.ebuild
parentEAPI bump; remove unrecognized configure options; dont try to install non-exi... (diff)
downloadhistorical-1f2d470b34e8600211205178726223951d3fad46.tar.gz
historical-1f2d470b34e8600211205178726223951d3fad46.tar.bz2
historical-1f2d470b34e8600211205178726223951d3fad46.zip
Clean up: remove /dev/shm checks (hopefully obsolete thanks to openrc), remove unused _WARNING variables, remove libsrtp from bundled libs exclusion list, switch to tc-arch for arch detection (for simplicity - we shouldn't have custom code for that).
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'www-client/chromium/chromium-9999-r1.ebuild')
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild32
1 files changed, 2 insertions, 30 deletions
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 21686fe5e547..6c34a769a715 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.30 2011/06/02 12:58:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.31 2011/06/02 18:40:41 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -128,19 +128,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- # Prevent user problems like bug #299777.
- if ! grep -q /dev/shm <<< $(get_mounts); then
- ewarn "You don't have tmpfs mounted at /dev/shm."
- ewarn "${PN} may fail to start in that configuration."
- ewarn "Please uncomment the /dev/shm entry in /etc/fstab,"
- ewarn "and run 'mount /dev/shm'."
- fi
- if [ `stat -c %a /dev/shm` -ne 1777 ]; then
- ewarn "/dev/shm does not have correct permissions."
- ewarn "${PN} may fail to start in that configuration."
- ewarn "Please run 'chmod 1777 /dev/shm'."
- fi
-
# Prevent user problems like bug #348235.
eshopts_push -s extglob
if is-flagq '-g?(gdb)?([1-9])'; then
@@ -153,8 +140,6 @@ pkg_setup() {
# Warn if the kernel doesn't support features useful for sandboxing,
# bug #363907.
CONFIG_CHECK="~PID_NS ~NET_NS"
- PID_NS_WARNING="PID (process id) namespaces are needed for sandboxing."
- NET_NS_WARNING="Network namespaces are needed for sandboxing."
check_extra_config
}
@@ -179,7 +164,6 @@ src_prepare() {
\! -path 'third_party/leveldb/*' \
\! -path 'third_party/libjingle/*' \
\! -path 'third_party/libphonenumber/*' \
- \! -path 'third_party/libsrtp/*' \
\! -path 'third_party/libvpx/libvpx.h' \
\! -path 'third_party/mesa/*' \
\! -path 'third_party/modp_b64/*' \
@@ -249,19 +233,7 @@ src_configure() {
# for Chromium.
myconf+=" -Dproprietary_codecs=1"
- # Use target arch detection logic from bug #354601.
- case ${CHOST} in
- i?86-*) myarch=x86 ;;
- x86_64-*)
- if [[ $ABI = "" ]] ; then
- myarch=amd64
- else
- myarch="$ABI"
- fi ;;
- arm*-*) myarch=arm ;;
- *) die "Unrecognized CHOST: ${CHOST}"
- esac
-
+ local myarch="$(tc-arch)"
if [[ $myarch = amd64 ]] ; then
myconf+=" -Dtarget_arch=x64"
elif [[ $myarch = x86 ]] ; then